aboutsummaryrefslogtreecommitdiffstats
path: root/components/servo/Cargo.toml
diff options
context:
space:
mode:
authorMartin Robinson <mrobinson@igalia.com>2025-04-16 09:54:54 +0200
committerGitHub <noreply@github.com>2025-04-16 07:54:54 +0000
commit6bad65a5a16c5a90b09fe8d0441c1d473e46e060 (patch)
treedad9b6631fd4b93f570191f96630bcb2fe33f7d4 /components/servo/Cargo.toml
parent9aa09d73b5d82406b0d922a30f30b65ffcf9eb96 (diff)
downloadservo-6bad65a5a16c5a90b09fe8d0441c1d473e46e060.tar.gz
servo-6bad65a5a16c5a90b09fe8d0441c1d473e46e060.zip
libservo: Allow running more than one Servo test in a run (#36532)
A `Servo` instance can only be constructed once per program execution and cannot be passed between threads. This change adds a special thread to run `Servo` unit tests. This will allow creating suites of `WebView` unit tests. Testing: This change includes a new test. Signed-off-by: Martin Robinson <mrobinson@igalia.com>
Diffstat (limited to 'components/servo/Cargo.toml')
-rw-r--r--components/servo/Cargo.toml1
1 files changed, 1 insertions, 0 deletions
diff --git a/components/servo/Cargo.toml b/components/servo/Cargo.toml
index 158dae236b8..e4347d76af0 100644
--- a/components/servo/Cargo.toml
+++ b/components/servo/Cargo.toml
@@ -124,6 +124,7 @@ gaol = "0.2.1"
webxr = { path = "../webxr", features = ["ipc", "glwindow", "headless", "openxr-api"] }
[dev-dependencies]
+anyhow = "1.0.97"
http = { workspace = true }
libservo = { path = ".", features = ["tracing"] }
rustls = { version = "0.23", default-features = false, features = ["aws-lc-rs"] }