aboutsummaryrefslogtreecommitdiffstats
path: root/ports/servo
diff options
context:
space:
mode:
Diffstat (limited to 'ports/servo')
-rw-r--r--ports/servo/Cargo.toml3
-rw-r--r--ports/servo/main.rs8
2 files changed, 6 insertions, 5 deletions
diff --git a/ports/servo/Cargo.toml b/ports/servo/Cargo.toml
index d9ab8a459c9..23f12909766 100644
--- a/ports/servo/Cargo.toml
+++ b/ports/servo/Cargo.toml
@@ -22,8 +22,9 @@ net_traits_tests = {path = "../../tests/unit/net_traits"}
plugin_compiletest = {path = "../../tests/compiletest/plugin"}
profile_tests = {path = "../../tests/unit/profile"}
script_tests = {path = "../../tests/unit/script"}
+servo_config_tests = {path = "../../tests/unit/servo_config"}
+servo_remutex_tests = {path = "../../tests/unit/servo_remutex"}
style_tests = {path = "../../tests/unit/style"}
-util_tests = {path = "../../tests/unit/util"}
[features]
default = ["webdriver", "max_log_level"]
diff --git a/ports/servo/main.rs b/ports/servo/main.rs
index 89bac711f53..cefc093af7a 100644
--- a/ports/servo/main.rs
+++ b/ports/servo/main.rs
@@ -38,8 +38,8 @@ extern crate sig;
use backtrace::Backtrace;
use servo::Browser;
use servo::compositing::windowing::WindowEvent;
-use servo::util::opts::{self, ArgumentParsingResult};
-use servo::util::servo_version;
+use servo::config::opts::{self, ArgumentParsingResult};
+use servo::config::servo_version;
use std::env;
use std::panic;
use std::process;
@@ -286,10 +286,10 @@ mod android {
use self::libc::{pipe, dup2};
use self::libc::fdopen;
use self::libc::fgets;
- use servo::util::thread::spawn_named;
use std::ffi::CStr;
use std::ffi::CString;
use std::str::from_utf8;
+ use std::thread;
unsafe {
let mut pipes: [c_int; 2] = [ 0, 0 ];
@@ -297,7 +297,7 @@ mod android {
dup2(pipes[1], file_no);
let mode = CString::new("r").unwrap();
let input_file = FilePtr(fdopen(pipes[0], mode.as_ptr()));
- spawn_named("android-logger".to_owned(), move || {
+ thread::Builder::new().name("android-logger".to_owned()).spawn(move || {
static READ_SIZE: usize = 1024;
let mut read_buffer = vec![0; READ_SIZE];
let FilePtr(input_file) = input_file;