aboutsummaryrefslogtreecommitdiffstats
path: root/components/servo_tracing/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'components/servo_tracing/Cargo.toml')
-rw-r--r--components/servo_tracing/Cargo.toml21
1 files changed, 21 insertions, 0 deletions
diff --git a/components/servo_tracing/Cargo.toml b/components/servo_tracing/Cargo.toml
new file mode 100644
index 00000000000..1660aa7f691
--- /dev/null
+++ b/components/servo_tracing/Cargo.toml
@@ -0,0 +1,21 @@
+[package]
+name = "servo-tracing"
+edition.workspace = true
+version.workspace = true
+authors.workspace = true
+license.workspace = true
+publish.workspace = true
+rust-version.workspace = true
+
+[dependencies]
+quote = { workspace = true }
+proc-macro2 = { workspace = true }
+syn = { version = "2", features = ["full"] }
+
+[lib]
+path = "lib.rs"
+proc-macro = true
+doctest = false
+
+[dev-dependencies]
+prettyplease = "0.2.32"