aboutsummaryrefslogtreecommitdiffstats
path: root/components/layout_thread/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'components/layout_thread/Cargo.toml')
-rw-r--r--components/layout_thread/Cargo.toml36
1 files changed, 36 insertions, 0 deletions
diff --git a/components/layout_thread/Cargo.toml b/components/layout_thread/Cargo.toml
new file mode 100644
index 00000000000..050fea38197
--- /dev/null
+++ b/components/layout_thread/Cargo.toml
@@ -0,0 +1,36 @@
+[package]
+name = "layout_thread"
+version = "0.0.1"
+authors = ["The Servo Project Developers"]
+publish = false
+
+[lib]
+name = "layout_thread"
+path = "lib.rs"
+
+[dependencies]
+app_units = {version = "0.2.3", features = ["plugins"]}
+azure = {git = "https://github.com/servo/rust-azure", features = ["plugins"]}
+euclid = {version = "0.6.4", features = ["plugins"]}
+fnv = "1.0"
+gfx = {path = "../gfx"}
+gfx_traits = {path = "../gfx_traits"}
+heapsize = "0.3.0"
+heapsize_plugin = "0.1.2"
+ipc-channel = {git = "https://github.com/servo/ipc-channel"}
+layout = {path = "../layout"}
+layout_traits = {path = "../layout_traits"}
+log = "0.3.5"
+msg = {path = "../msg"}
+net_traits = {path = "../net_traits"}
+plugins = {path = "../plugins"}
+profile_traits = {path = "../profile_traits"}
+script = {path = "../script"}
+script_layout_interface = {path = "../script_layout_interface"}
+script_traits = {path = "../script_traits"}
+serde_json = "0.7"
+serde_macros = "0.7"
+style = {path = "../style"}
+url = {version = "1.0.0", features = ["heap_size"]}
+util = {path = "../util"}
+webrender_traits = {git = "https://github.com/servo/webrender_traits"}