aboutsummaryrefslogtreecommitdiffstats
path: root/python/tidy/setup.py
diff options
context:
space:
mode:
authorbors-servo <lbergstrom+bors@mozilla.com>2019-06-03 13:08:48 -0400
committerGitHub <noreply@github.com>2019-06-03 13:08:48 -0400
commitbdc584f3ed31dcb94e7b49a9977ab2e6a512c9fd (patch)
tree54d0f05245ee3d03523e76b793dd1418a5286b1e /python/tidy/setup.py
parent657ed9f1ca0c389d6d668acbe9cf4d5aca18579e (diff)
parent7d658c990f436dd3f8b821c18b14c10a0e28c738 (diff)
downloadservo-bdc584f3ed31dcb94e7b49a9977ab2e6a512c9fd.tar.gz
servo-bdc584f3ed31dcb94e7b49a9977ab2e6a512c9fd.zip
Auto merge of #23400 - staktrace:patch-1, r=jdm
Include missing dependency requirements Running `servo-tidy` in a virtualenv where all you've done is `pip install servo-tidy==0.3.0` doesn't actually work because of missing dependencies. PyYAML and voluptuous are required as well. I don't know anything about python package management but declaring these missing dependencies seems like an appropriate thing to do. Patch itself is untested because I don't know how, although with these dependencies installed in my virtualenv running `servo-tidy` works. <!-- Please describe your changes on the following line: --> --- <!-- Thank you for contributing to Servo! Please replace each `[ ]` by `[X]` when the step is complete, and replace `___` with appropriate data: --> - [ ] `./mach build -d` does not report any errors - [ ] `./mach test-tidy` does not report any errors - [ ] These changes fix #___ (GitHub issue number if applicable) <!-- Either: --> - [ ] There are tests for these changes OR - [ ] These changes do not require tests because ___ <!-- Also, please make sure that "Allow edits from maintainers" checkbox is checked, so that we can help you if you get stuck somewhere along the way.--> <!-- Pull requests that do not address these steps are welcome, but they will require additional verification as part of the review process. --> <!-- Reviewable:start --> --- This change is [<img src="https://reviewable.io/review_button.svg" height="34" align="absmiddle" alt="Reviewable"/>](https://reviewable.io/reviews/servo/servo/23400) <!-- Reviewable:end -->
Diffstat (limited to 'python/tidy/setup.py')
-rw-r--r--python/tidy/setup.py2
1 files changed, 2 insertions, 0 deletions
diff --git a/python/tidy/setup.py b/python/tidy/setup.py
index c761bea7b2f..66229fe4c91 100644
--- a/python/tidy/setup.py
+++ b/python/tidy/setup.py
@@ -17,6 +17,8 @@ install_requires = [
"flake8==2.4.1",
"toml==0.9.2",
"colorama==0.3.7",
+ "voluptuous==0.11.5",
+ "PyYAML==5.1",
]
here = os.path.dirname(os.path.abspath(__file__))