aboutsummaryrefslogtreecommitdiffstats
path: root/python/mach/setup.py
diff options
context:
space:
mode:
authorCorey Farwell <coreyf@rwell.org>2016-05-02 18:07:43 -0400
committerCorey Farwell <coreyf@rwell.org>2016-05-02 19:27:52 -0400
commit7725e644e94df722ca20ddc95f7aafe1ba19abae (patch)
tree32a236c060fd5a2672a17c8e6e376aab1c842751 /python/mach/setup.py
parenta8e82440ff5ba790e40b4e6437e9882b4f4619c4 (diff)
downloadservo-7725e644e94df722ca20ddc95f7aafe1ba19abae.tar.gz
servo-7725e644e94df722ca20ddc95f7aafe1ba19abae.zip
Upgrade mach to 0.6; stop vendoring mach.
When I originally rewrote Servo's mach bootstrapping (using virtualenv w/ requirements.txt in #7103), I didn't specify mach as a requirement because a new version hadn't been published in a while. Now that 0.6 is out, I asked the mach maintainers to publish a new version on PyPI, so now we can fetch it like the other Python dependencies. Fixes https://github.com/servo/servo/issues/10728.
Diffstat (limited to 'python/mach/setup.py')
-rw-r--r--python/mach/setup.py38
1 files changed, 0 insertions, 38 deletions
diff --git a/python/mach/setup.py b/python/mach/setup.py
deleted file mode 100644
index 511a6a32277..00000000000
--- a/python/mach/setup.py
+++ /dev/null
@@ -1,38 +0,0 @@
-# This Source Code Form is subject to the terms of the Mozilla Public
-# License, v. 2.0. If a copy of the MPL was not distributed with this
-# file, You can obtain one at http://mozilla.org/MPL/2.0/.
-
-try:
- from setuptools import setup
-except:
- from distutils.core import setup
-
-
-VERSION = '0.3'
-
-README = open('README.rst').read()
-
-setup(
- name='mach',
- description='Generic command line command dispatching framework.',
- long_description=README,
- license='MPL 2.0',
- author='Gregory Szorc',
- author_email='gregory.szorc@gmail.com',
- url='https://developer.mozilla.org/en-US/docs/Developer_Guide/mach',
- packages=['mach'],
- version=VERSION,
- classifiers=[
- 'Environment :: Console',
- 'Development Status :: 3 - Alpha',
- 'License :: OSI Approved :: Mozilla Public License 2.0 (MPL 2.0)',
- 'Natural Language :: English',
- ],
- install_requires=[
- 'blessings',
- 'mozfile',
- 'mozprocess',
- ],
- tests_require=['mock'],
-)
-