aboutsummaryrefslogtreecommitdiffstats
path: root/ports/servoshell/Cargo.toml
diff options
context:
space:
mode:
authorMartin Robinson <mrobinson@igalia.com>2024-06-17 10:27:50 +0200
committerGitHub <noreply@github.com>2024-06-17 08:27:50 +0000
commite902d63732e96f71c86bae159786e12b18876b3c (patch)
treeb7de256cb560fc9f823fdcccbfcaba2b2cd54ca3 /ports/servoshell/Cargo.toml
parent8b35c4094a44e3d47ebfa5c7ff11b15ec6b22b05 (diff)
downloadservo-e902d63732e96f71c86bae159786e12b18876b3c.tar.gz
servo-e902d63732e96f71c86bae159786e12b18876b3c.zip
deps: Switch from `winapi` to `windows_sys` in Servo code (#32516)
This is part of the switch from `winapi` to `windows-sys`. `windows-sys` is maintained by Microsoft, so is more "official." More and more crates are switching to it.
Diffstat (limited to 'ports/servoshell/Cargo.toml')
-rw-r--r--ports/servoshell/Cargo.toml2
1 files changed, 1 insertions, 1 deletions
diff --git a/ports/servoshell/Cargo.toml b/ports/servoshell/Cargo.toml
index fb28678d80d..93a311dcd88 100644
--- a/ports/servoshell/Cargo.toml
+++ b/ports/servoshell/Cargo.toml
@@ -92,4 +92,4 @@ image = { workspace = true }
sig = "1.0"
[target.'cfg(target_os = "windows")'.dependencies]
-winapi = { workspace = true, features = ["wingdi", "winuser", "winnt", "winbase", "processenv", "namedpipeapi", "ntdef", "minwindef", "handleapi", "debugapi"] }
+windows-sys = { workspace = true, features = ["Win32_Graphics_Gdi"] }