aboutsummaryrefslogtreecommitdiffstats
path: root/ports/servoshell/Cargo.toml
diff options
context:
space:
mode:
authorDelan Azabani <dazabani@igalia.com>2024-11-13 17:52:26 +0800
committerGitHub <noreply@github.com>2024-11-13 09:52:26 +0000
commitc00804190cdc256183ade8f050d5f0408b550303 (patch)
tree1b8e1d161a99d6f4748f115e1299e0b8d2df99d4 /ports/servoshell/Cargo.toml
parent873e82a5329dffeeef9c91d0e47cf34c41c53b03 (diff)
downloadservo-c00804190cdc256183ade8f050d5f0408b550303.tar.gz
servo-c00804190cdc256183ade8f050d5f0408b550303.zip
Allow filtering of tracing events via SERVO_TRACING (#34236)
* Allow filtering of tracing events via SERVO_TRACING Signed-off-by: Delan Azabani <dazabani@igalia.com> * Assume SERVO_TRACING=off by default Signed-off-by: Delan Azabani <dazabani@igalia.com> --------- Signed-off-by: Delan Azabani <dazabani@igalia.com>
Diffstat (limited to 'ports/servoshell/Cargo.toml')
-rw-r--r--ports/servoshell/Cargo.toml2
1 files changed, 1 insertions, 1 deletions
diff --git a/ports/servoshell/Cargo.toml b/ports/servoshell/Cargo.toml
index ea2e5584640..a1d0cbf3829 100644
--- a/ports/servoshell/Cargo.toml
+++ b/ports/servoshell/Cargo.toml
@@ -67,7 +67,7 @@ url = { workspace = true }
servo-media = { workspace = true }
tokio = { workspace = true }
tracing = { workspace = true, optional = true }
-tracing-subscriber = { workspace = true, optional = true }
+tracing-subscriber = { workspace = true, optional = true, features = ["env-filter"] }
tracing-perfetto = { workspace = true, optional = true }
[target.'cfg(target_os = "android")'.dependencies]