aboutsummaryrefslogtreecommitdiffstats
path: root/ports/jniapi
diff options
context:
space:
mode:
authorMartin Robinson <mrobinson@igalia.com>2024-03-14 18:40:54 +0100
committerGitHub <noreply@github.com>2024-03-14 17:40:54 +0000
commitad37a54f59f4eef2c8f815a3a59ab7d928b2946f (patch)
treee78d14062c6f8d807411ee535d0e426b9798f6aa /ports/jniapi
parent4597aeae5f9b1d76d6af664afdbb72647908e907 (diff)
downloadservo-ad37a54f59f4eef2c8f815a3a59ab7d928b2946f.tar.gz
servo-ad37a54f59f4eef2c8f815a3a59ab7d928b2946f.zip
dependencies: Upgrade to WebRender 0.64 (#31486)
This brings the version of WebRender used in Servo up-to-date with Gecko upstream. The big change here is that HiDPI is no longer handled via WebRender. Instead this happens via a scale applied to the root layer in the compositor. In addition to this change, various changes are made to Servo to adapt to the new WebRender API. Co-authored-by: Mukilan Thiyagarajan <mukilan@igalia.com>
Diffstat (limited to 'ports/jniapi')
-rw-r--r--ports/jniapi/Cargo.toml2
-rw-r--r--ports/jniapi/src/simpleservo.rs2
2 files changed, 2 insertions, 2 deletions
diff --git a/ports/jniapi/Cargo.toml b/ports/jniapi/Cargo.toml
index 533769a913b..c8fa1f4e8cd 100644
--- a/ports/jniapi/Cargo.toml
+++ b/ports/jniapi/Cargo.toml
@@ -44,7 +44,7 @@ js_backtrace = ["libservo/js_backtrace"]
max_log_level = ["log/release_max_level_info"]
media-gstreamer = ["libservo/media-gstreamer"]
native-bluetooth = ["libservo/native-bluetooth"]
-no_static_freetype = ["libservo/no_static_freetype"]
+dynamic_freetype = ["libservo/dynamic_freetype"]
no-wgl = ["libservo/no-wgl"]
profilemozjs = ["libservo/profilemozjs"]
refcell_backtrace = ["libservo/refcell_backtrace"]
diff --git a/ports/jniapi/src/simpleservo.rs b/ports/jniapi/src/simpleservo.rs
index 3238eb182d1..cd53b74a315 100644
--- a/ports/jniapi/src/simpleservo.rs
+++ b/ports/jniapi/src/simpleservo.rs
@@ -891,7 +891,7 @@ impl WindowMethods for ServoWindowCallbacks {
fn get_coordinates(&self) -> EmbedderCoordinates {
let coords = self.coordinates.borrow();
EmbedderCoordinates {
- viewport: coords.viewport,
+ viewport: coords.viewport.to_box2d(),
framebuffer: coords.framebuffer,
window: (coords.viewport.size, Point2D::new(0, 0)),
screen: coords.viewport.size,