aboutsummaryrefslogtreecommitdiffstats
path: root/etc/shell.nix
diff options
context:
space:
mode:
authorDelan Azabani <dazabani@igalia.com>2024-01-11 16:10:51 +0800
committerGitHub <noreply@github.com>2024-01-11 08:10:51 +0000
commit1f1cf1499d1e249c58fb3ac8986e62cf0d796497 (patch)
tree9af2b99c0191b156db64b485d60bc229bf032716 /etc/shell.nix
parent92196d985dceb0ca708b097e2a847b255d8387c8 (diff)
downloadservo-1f1cf1499d1e249c58fb3ac8986e62cf0d796497.tar.gz
servo-1f1cf1499d1e249c58fb3ac8986e62cf0d796497.zip
Nix: bump nixpkgs to nixos-unstable (#31055)
* Nix: bump nixpkgs to nixos-unstable (except gnumake + clang) * we can get clang 11 from nixos-unstable * bump clang to 15 * simplify approach now that we get clang from nixos-unstable * drop clang to version 14 (#31059)
Diffstat (limited to 'etc/shell.nix')
-rw-r--r--etc/shell.nix11
1 files changed, 9 insertions, 2 deletions
diff --git a/etc/shell.nix b/etc/shell.nix
index 59c952bd025..39c8ff2eea9 100644
--- a/etc/shell.nix
+++ b/etc/shell.nix
@@ -2,7 +2,7 @@
# NOTE: This does not work offline or for nix-build
with import (builtins.fetchTarball {
- url = "https://github.com/NixOS/nixpkgs/archive/70bdadeb94ffc8806c0570eb5c2695ad29f0e421.tar.gz";
+ url = "https://github.com/NixOS/nixpkgs/archive/46ae0210ce163b3cba6c7da08840c1d63de9c701.tar.gz";
}) {
overlays = [
(import (builtins.fetchTarball {
@@ -20,8 +20,15 @@ let
pkgs_gnumake_4_3 = import (builtins.fetchTarball {
url = "https://github.com/NixOS/nixpkgs/archive/6adf48f53d819a7b6e15672817fa1e78e5f4e84f.tar.gz";
}) {};
+
+ # We need clangStdenv with:
+ # - clang < 16 (#30587)
+ # - clang < 15 (#31059)
+ # - glibc 2.38 (#31054)
+ llvmPackages = llvmPackages_14;
+ stdenv = llvmPackages.stdenv;
in
-clangStdenv.mkDerivation rec {
+stdenv.mkDerivation rec {
name = "servo-env";
buildInputs = [