aboutsummaryrefslogtreecommitdiffstats
path: root/components/webxr/Cargo.toml
diff options
context:
space:
mode:
authorMartin Robinson <mrobinson@igalia.com>2025-04-16 18:58:52 +0200
committerGitHub <noreply@github.com>2025-04-16 16:58:52 +0000
commitd8a7abda69dc2e03a845cb053c28764babd5b9de (patch)
treebb15a30aa8729eda1feaeec4ea9a9d7294020be7 /components/webxr/Cargo.toml
parent7a8e75266ff2c138f212a301de9774eafb2b3143 (diff)
downloadservo-d8a7abda69dc2e03a845cb053c28764babd5b9de.tar.gz
servo-d8a7abda69dc2e03a845cb053c28764babd5b9de.zip
libservo: Expose a `ServoBuilder` (#36549)
Expose a `ServoBuilder` for easily creating Servo instances using default values. This change enables removing `EmbedderTraits`. Testing: This is covered by `Servo` unit tests. Signed-off-by: Martin Robinson <mrobinson@igalia.com> Signed-off-by: Martin Robinson <mrobinson@igalia.com>
Diffstat (limited to 'components/webxr/Cargo.toml')
-rw-r--r--components/webxr/Cargo.toml1
1 files changed, 1 insertions, 0 deletions
diff --git a/components/webxr/Cargo.toml b/components/webxr/Cargo.toml
index 809e8483bd4..49315ac41db 100644
--- a/components/webxr/Cargo.toml
+++ b/components/webxr/Cargo.toml
@@ -26,6 +26,7 @@ openxr-api = ["angle", "openxr", "winapi", "wio", "surfman/sm-angle-default"]
[dependencies]
crossbeam-channel = { workspace = true }
+embedder_traits = { workspace = true }
euclid = { workspace = true }
glow = { workspace = true }
log = { workspace = true }