aboutsummaryrefslogtreecommitdiffstats
path: root/components/style_traits/Cargo.toml
diff options
context:
space:
mode:
authorTom Tromey <tom@tromey.com>2017-09-11 14:19:04 -0600
committerTom Tromey <tom@tromey.com>2017-09-12 07:35:55 -0600
commit4768597b130915a2032abf87a84dc72459cb0687 (patch)
tree1e0c008ef906b0e5959365f534a5a9e3e822025e /components/style_traits/Cargo.toml
parent61fac2c10de5e0d4ce9d559e0effe2582dcbadb2 (diff)
downloadservo-4768597b130915a2032abf87a84dc72459cb0687.tar.gz
servo-4768597b130915a2032abf87a84dc72459cb0687.zip
Remove get_location_with_offset
Now that rust-cssparser reports 1-based locations, bump the required cssparser version and remove get_location_with_offset. Previously, some code paths were not calling get_location_with_offset; see https://bugzilla.mozilla.org/show_bug.cgi?id=1398869 for some background.
Diffstat (limited to 'components/style_traits/Cargo.toml')
-rw-r--r--components/style_traits/Cargo.toml2
1 files changed, 1 insertions, 1 deletions
diff --git a/components/style_traits/Cargo.toml b/components/style_traits/Cargo.toml
index 0e29ef33646..95cee727ef7 100644
--- a/components/style_traits/Cargo.toml
+++ b/components/style_traits/Cargo.toml
@@ -16,7 +16,7 @@ gecko = []
[dependencies]
app_units = "0.5"
bitflags = "0.7"
-cssparser = "0.20.2"
+cssparser = "0.21.0"
euclid = "0.15"
heapsize = {version = "0.4", optional = true}
heapsize_derive = {version = "0.1", optional = true}