aboutsummaryrefslogtreecommitdiffstats
path: root/components/style/Cargo.toml
diff options
context:
space:
mode:
authorDelan Azabani <dazabani@igalia.com>2024-02-22 17:56:26 +0800
committerGitHub <noreply@github.com>2024-02-22 09:56:26 +0000
commitf60e5e767b5002e9a440cf5d6e63f462d3e85a8e (patch)
tree504d197a01d8f8569fe05b6f8f306fef8d7b53f8 /components/style/Cargo.toml
parent1c2de6dd1d31304187dd9b2e5767681fe16cd68f (diff)
downloadservo-f60e5e767b5002e9a440cf5d6e63f462d3e85a8e.tar.gz
servo-f60e5e767b5002e9a440cf5d6e63f462d3e85a8e.zip
Revert remaining Stylo changes (#31408)
* Revert remaining changes from Stylo split-into-commits branch * Do the minimum amount of formatting to appease mach test-tidy
Diffstat (limited to 'components/style/Cargo.toml')
-rw-r--r--components/style/Cargo.toml6
1 files changed, 3 insertions, 3 deletions
diff --git a/components/style/Cargo.toml b/components/style/Cargo.toml
index c4d99da653a..dc431fce5d3 100644
--- a/components/style/Cargo.toml
+++ b/components/style/Cargo.toml
@@ -64,7 +64,7 @@ owning_ref = "0.4"
parking_lot = "0.12"
precomputed-hash = "0.1.1"
rayon = "1"
-selectors = { path = "../selectors", features = ["shmem"] }
+selectors = { path = "../selectors" }
serde = { version = "1.0", optional = true, features = ["derive"] }
servo_arc = { path = "../servo_arc" }
servo_atoms = { path = "../atoms", optional = true }
@@ -75,15 +75,15 @@ static_assertions = "1.1"
static_prefs = { path = "../style_static_prefs" }
string_cache = { version = "0.8", optional = true }
style_derive = { path = "../style_derive" }
-style_traits = { workspace = true }
+style_traits = { path = "../style_traits" }
time = "0.1"
thin-vec = { workspace = true }
to_shmem = { path = "../to_shmem" }
to_shmem_derive = { path = "../to_shmem_derive" }
-url = { workspace = true, optional = true, features = ["serde"] }
uluru = "3.0"
unicode-bidi = "0.3"
unicode-segmentation = "1.0"
+url = { workspace = true, optional = true }
void = "1.0.2"
[build-dependencies]