aboutsummaryrefslogtreecommitdiffstats
path: root/components/script/Cargo.toml
diff options
context:
space:
mode:
authorMartin Robinson <mrobinson@igalia.com>2024-02-22 15:15:59 +0100
committerGitHub <noreply@github.com>2024-02-22 14:15:59 +0000
commitd8b326528b3d0646ef08714b87958f701cf89c88 (patch)
tree5027983cff9e39f5efdef3ba3d11266dc5fe58a7 /components/script/Cargo.toml
parentf60e5e767b5002e9a440cf5d6e63f462d3e85a8e (diff)
downloadservo-d8b326528b3d0646ef08714b87958f701cf89c88.tar.gz
servo-d8b326528b3d0646ef08714b87958f701cf89c88.zip
layout: Add initial support for `text-transform` (#31396)
This adds basic support for `text-transform` in a way that is more complete than legacy layout. There are still many missing elements of proper `text-transform` support such as: 1. Support for `full-width` and `full-size-kana` 2. Support for grapheme based uppercasing, lowercasing, and capitalization. These are all done per-code point right now. 3. Support for the language-specific `SpecialCasing.txt` cases for case mapping such as the ones for Irish and Turkish. Co-authored-by: Rakhi Sharma <atbrakhi@igalia.com>
Diffstat (limited to 'components/script/Cargo.toml')
-rw-r--r--components/script/Cargo.toml2
1 files changed, 1 insertions, 1 deletions
diff --git a/components/script/Cargo.toml b/components/script/Cargo.toml
index 8e3b4eef5a2..31e6c6b466a 100644
--- a/components/script/Cargo.toml
+++ b/components/script/Cargo.toml
@@ -107,7 +107,7 @@ tempfile = "3"
tendril = { version = "0.4.1", features = ["encoding_rs"] }
time = { workspace = true }
unicode-bidi = { workspace = true }
-unicode-segmentation = "1.1.0"
+unicode-segmentation = { workspace = true }
url = { workspace = true }
utf-8 = "0.7"
uuid = { workspace = true, features = ["serde"] }