aboutsummaryrefslogtreecommitdiffstats
path: root/components/compositing/Cargo.toml
diff options
context:
space:
mode:
authorMartin Robinson <mrobinson@igalia.com>2024-01-27 18:58:34 +0100
committerGitHub <noreply@github.com>2024-01-27 17:58:34 +0000
commitbc211f8ff387ea59bc8af7bb7394c7be7ca69597 (patch)
tree853b9a211de6e63d4d31295200bb86afb9c442a9 /components/compositing/Cargo.toml
parentbbe505e52b611e682c6f3b34411a07c00a34f2b7 (diff)
downloadservo-bc211f8ff387ea59bc8af7bb7394c7be7ca69597.tar.gz
servo-bc211f8ff387ea59bc8af7bb7394c7be7ca69597.zip
gfx: Rename `WebrenderSurfman` to `RenderingContext` and move to `gfx` (#31184)
This is a small cleanup that moves and renames this class. The rename is simply because we are exposing a lot about the details of Servo's rendering in the API and it makes sense to start thinking about abstracting that away a bit. This also moves the struct to `gfx`, which does have an effect on Servo's dependency graph. This adds a new dependency on gfx to `compositing`, but `compositing` had a transitive dependency on gfx before through `canvas`.
Diffstat (limited to 'components/compositing/Cargo.toml')
-rw-r--r--components/compositing/Cargo.toml2
1 files changed, 1 insertions, 1 deletions
diff --git a/components/compositing/Cargo.toml b/components/compositing/Cargo.toml
index 861164b6cc0..10c651bcb81 100644
--- a/components/compositing/Cargo.toml
+++ b/components/compositing/Cargo.toml
@@ -22,6 +22,7 @@ crossbeam-channel = { workspace = true }
embedder_traits = { workspace = true }
euclid = { workspace = true }
fnv = { workspace = true }
+gfx = { path = "../gfx" }
gfx_traits = { workspace = true }
gleam = { workspace = true }
image = { workspace = true }
@@ -42,7 +43,6 @@ style_traits = { workspace = true }
time = { workspace = true }
webrender = { workspace = true }
webrender_api = { workspace = true }
-webrender_surfman = { path = "../webrender_surfman" }
webxr = { git = "https://github.com/servo/webxr" }
[build-dependencies]