aboutsummaryrefslogtreecommitdiffstats
path: root/components/compositing/Cargo.toml
diff options
context:
space:
mode:
authorJosh Matthews <josh@joshmatthews.net>2020-06-08 13:53:33 -0400
committerJosh Matthews <josh@joshmatthews.net>2020-06-09 13:05:16 -0400
commit75efaa95f53dd0f110d02d5d4009bb491290af4d (patch)
treeface9912a579fe911f9a43b11dbc7f0c7f71a5b2 /components/compositing/Cargo.toml
parenta6016b3a62804788ad23358e34fa5c1f50716f9a (diff)
downloadservo-75efaa95f53dd0f110d02d5d4009bb491290af4d.tar.gz
servo-75efaa95f53dd0f110d02d5d4009bb491290af4d.zip
Proxy all WR interactions for layout/font/script/canvas threads to the compositor
thread. There is now a single RenderApi that is used, and all transactions are serialized through the compositor.
Diffstat (limited to 'components/compositing/Cargo.toml')
-rw-r--r--components/compositing/Cargo.toml1
1 files changed, 1 insertions, 0 deletions
diff --git a/components/compositing/Cargo.toml b/components/compositing/Cargo.toml
index 027d16233bf..97419f37752 100644
--- a/components/compositing/Cargo.toml
+++ b/components/compositing/Cargo.toml
@@ -16,6 +16,7 @@ default = []
gl = ["gleam", "pixels"]
[dependencies]
+app_units = "0.7"
canvas = { path = "../canvas" }
crossbeam-channel = "0.4"
embedder_traits = { path = "../embedder_traits" }