aboutsummaryrefslogtreecommitdiffstats
path: root/components/compositing/Cargo.toml
diff options
context:
space:
mode:
authorMartin Robinson <mrobinson@igalia.com>2025-02-17 09:35:05 +0100
committerGitHub <noreply@github.com>2025-02-17 08:35:05 +0000
commit6dce329acc67ee55b2a640add7791ace0be0180d (patch)
treee23f7c0fa7871c08d49a8eacb5a590d9f1e12709 /components/compositing/Cargo.toml
parentd466688526734c9eccfeebfe8e71bf1cbe69b192 (diff)
downloadservo-6dce329acc67ee55b2a640add7791ace0be0180d.tar.gz
servo-6dce329acc67ee55b2a640add7791ace0be0180d.zip
libservo: Expose an `OffscreenRenderingContext` and use it for servoshell (#35465)
Create a new `RenderingContext` which is used to render to a `SurfmanRenderingContext`-related offscreen buffer. This allows having a temporary place to render Servo and then blitting the results to a subsection of the parent `RenderingContext`. The goal with this change is to remove the details of how servoshell renders from the `Compositor` and prepare for the compositor-per-WebView world. Co-authred-by: Ngo Iok Ui (Wu Yu Wei) <yuweiwu@pm.me> Signed-off-by: Martin Robinson <mrobinson@igalia.com> Co-authored-by: Mukilan Thiyagarajan <mukilan@igalia.com>
Diffstat (limited to 'components/compositing/Cargo.toml')
-rw-r--r--components/compositing/Cargo.toml1
1 files changed, 1 insertions, 0 deletions
diff --git a/components/compositing/Cargo.toml b/components/compositing/Cargo.toml
index 4382036accc..6c7d2df2c1f 100644
--- a/components/compositing/Cargo.toml
+++ b/components/compositing/Cargo.toml
@@ -36,6 +36,7 @@ script_traits = { workspace = true }
servo_config = { path = "../config" }
servo_geometry = { path = "../geometry" }
style_traits = { workspace = true }
+surfman = { workspace = true }
tracing = { workspace = true, optional = true }
webrender = { workspace = true }
webrender_api = { workspace = true }