aboutsummaryrefslogtreecommitdiffstats
path: root/components/bluetooth_traits/Cargo.toml
diff options
context:
space:
mode:
authorSimon Sapin <simon.sapin@exyr.org>2018-10-07 12:13:51 +0200
committerSimon Sapin <simon.sapin@exyr.org>2018-10-07 13:27:23 +0200
commit1f7ebfc8a2977a54d6ee8cd1777b1cdb410ac719 (patch)
treef0ed93650f3143536c59077c5bd81064ce160a47 /components/bluetooth_traits/Cargo.toml
parent76ddbe4d7afd48b83b23f3fd0cff47b214a0a290 (diff)
downloadservo-1f7ebfc8a2977a54d6ee8cd1777b1cdb410ac719.tar.gz
servo-1f7ebfc8a2977a54d6ee8cd1777b1cdb410ac719.zip
Make `mach test-unit` not recompile components after `mach build`
Previously, the `tests` feature flag of the `embedder_traits` crate caused it and every crate recursively depending on it to be built twice. This feature flag was used to provide a specific set of "resources" when running tests. Instead, this commits overrides the `main()` function of the test harness to change resources at runtime before running any test. This is done by adding a dependency that has `name = "test"` in its `[lib]` section of `Cargo.toml`. This overrides the crate found by `extern crate test;` in code generated by `rustc --test`.
Diffstat (limited to 'components/bluetooth_traits/Cargo.toml')
-rw-r--r--components/bluetooth_traits/Cargo.toml3
1 files changed, 0 insertions, 3 deletions
diff --git a/components/bluetooth_traits/Cargo.toml b/components/bluetooth_traits/Cargo.toml
index 5446a996ebf..f21f289898c 100644
--- a/components/bluetooth_traits/Cargo.toml
+++ b/components/bluetooth_traits/Cargo.toml
@@ -14,6 +14,3 @@ ipc-channel = "0.11"
regex = "1.0"
serde = "1.0"
embedder_traits = { path = "../embedder_traits" }
-
-[dev-dependencies]
-embedder_traits = { path = "../embedder_traits", features = ["tests"] }