aboutsummaryrefslogtreecommitdiffstats
path: root/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml16
1 files changed, 4 insertions, 12 deletions
diff --git a/Cargo.toml b/Cargo.toml
index 4fe6734..9d828c0 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -3,19 +3,11 @@ name = "fortknox"
version = "0.1.0"
edition = "2021"
-# See more keys and their definitions at https://doc.rust-lang.org/cargo/reference/manifest.html
-
[dependencies]
+axum = "0.7.2"
+json = "0.12.4"
serde = "1.0.193"
sqlx = "0.7.3"
+tokio = { version = "1.35.1", features = ["full", "tracing"] }
+uuid = { version = "1.6.1", features =["v4", "v8", "fast-rng", "macro-diagnostics","serde", "bytemuck"]}
-[dependencies.uuid]
-version = "1.6.1"
-features = [
- "v4", # Lets you generate random UUIDs
- "v8", # Custom UUID format
- "fast-rng", # Use a faster (but still sufficiently random) RNG
- "macro-diagnostics", # Enable better diagnostics for compile-time UUIDs
- "serde",
- "bytemuck",
-]