Commit message (Collapse) | Author | Age | Files | Lines | |
---|---|---|---|---|---|
* | serviceworker: make job queue unique per origin | Gregory Terzian | 2020-05-21 | 1 | -342/+0 |
| | |||||
* | make is_origin_trustworthy a method of ServoUrl + fix localhost handling | Alexandrov Sergey | 2020-05-19 | 1 | -2/+1 |
| | |||||
* | Use `#![register_tool]` instead of `#![register_attr]` | Simon Sapin | 2019-11-15 | 1 | -2/+2 |
| | | | | CC https://github.com/rust-lang/rust/issues/66079 | ||||
* | Update Worker webidl to support WorkerOptions | CYBAI | 2019-05-11 | 1 | -0/+4 |
| | |||||
* | Update MPL license to https (part 3) | Jan Andre Ikenmeyer | 2018-11-19 | 1 | -1/+1 |
| | |||||
* | Reorder imports | Pyfisch | 2018-11-06 | 1 | -1/+1 |
| | |||||
* | Sort `use` statements | Simon Sapin | 2018-11-06 | 1 | -2/+2 |
| | |||||
* | `cargo fix --edition` | Simon Sapin | 2018-11-06 | 1 | -12/+12 |
| | |||||
* | Format script component | chansuke | 2018-09-19 | 1 | -27/+63 |
| | |||||
* | added pipelines to all task sources | ddh | 2017-10-25 | 1 | -10/+13 |
| | | | | changed task sources to accept pipeline ids | ||||
* | Rename DOMRefCell<T> to DomRefCell<T> | Anthony Ramine | 2017-09-26 | 1 | -3/+3 |
| | | | | | | | | I don't want to do such a gratuitous rename, but with all the other types now having "Dom" as part of their name, and especially with "DomOnceCell", I feel like the other cell type that we already have should also follow the convention. That argument loses weight though when we realise there is still DOMString and other things. | ||||
* | Rename JS<T> to Dom<T> | Anthony Ramine | 2017-09-26 | 1 | -3/+3 |
| | |||||
* | Rename dom::bindings::js to dom::bindings::root | Anthony Ramine | 2017-09-26 | 1 | -1/+1 |
| | |||||
* | Rename Promise::is_settled to Promise::is_fulfilled | Anthony Ramine | 2017-09-22 | 1 | -1/+1 |
| | |||||
* | Make Promise::reject_error sound | Anthony Ramine | 2017-09-22 | 1 | -6/+3 |
| | |||||
* | Make Promise::resolve_native actually sound | Anthony Ramine | 2017-09-21 | 1 | -1/+1 |
| | | | | | We shouldn't have to pass a raw JSContext pointer, and to enter the promise's context's compartment by hand. | ||||
* | Introduce TaskOnce | Anthony Ramine | 2017-09-20 | 1 | -1/+1 |
| | | | | | Having both TaskBox and TaskOnce allows us to remove the superfluous inner boxing from CancellableTask<T>. | ||||
* | Use task! to settle promises for jobs | Anthony Ramine | 2017-09-18 | 1 | -31/+10 |
| | |||||
* | Move Task to its own module | Anthony Ramine | 2017-09-18 | 1 | -1/+2 |
| | |||||
* | Introduce MainThreadScriptMsg::DispatchJobQueue | Anthony Ramine | 2017-09-17 | 1 | -27/+2 |
| | | | | This removes the last remaining use of Task::run_with_script_thread | ||||
* | Remove uses of AsyncJobHandler from script_thread | Anthony Ramine | 2017-09-17 | 1 | -10/+8 |
| | |||||
* | Send AsyncJobHandler as a MainThreadTask | Anthony Ramine | 2017-09-16 | 1 | -2/+4 |
| | |||||
* | Rename Runnable to Task | Anthony Ramine | 2017-09-16 | 1 | -5/+5 |
| | | | | | | | | | | | | The changes are: * `*Runnable` -> `*Task`; * `RunnableMsg` -> `Task`; * `RunnableWrapper` -> `TaskCanceller`; * `MainThreadRunnable` -> `MainThreadTask`; * `wrap_runnable` -> `wrap_task`; * `get_runnable_wrapper` -> `task_canceller`; * `handler` -> `run`; * `main_thread_handler` -> `run_with_script_thread`. | ||||
* | order derivable traits lists | Clément DAVID | 2017-08-23 | 1 | -1/+1 |
| | | | | | | Ignoring : - **generated**.rs - python/tidy/servo_tidy_tests/rust_tidy.rs | ||||
* | Remove incorrect uses of asynchronous tasks from ServiceWorker job queue. | Josh Matthews | 2017-02-01 | 1 | -97/+153 |
| | |||||
* | Rename `Reflectable` to `DomObject`. | Corey Farwell | 2016-12-08 | 1 | -1/+1 |
| | | | | Fixes https://github.com/servo/servo/issues/8473. | ||||
* | Initial work on job queues for service workers | Rahul Sharma | 2016-11-22 | 1 | -0/+292 |