Commit message (Collapse) | Author | Age | Files | Lines | |
---|---|---|---|---|---|
* | Generate a trait abstracting over all known DOM interfaces (#34357) | Josh Matthews | 2024-11-24 | 1 | -1/+1 |
| | | | | | | | | | | | | | | | | | * script: Generate trait for all DOM interfaces and parameterize generated Methods traits over it. Signed-off-by: Josh Matthews <josh@joshmatthews.net> * script: Update trait implementations with new generic type. Signed-off-by: Josh Matthews <josh@joshmatthews.net> * Formatting. Signed-off-by: Josh Matthews <josh@joshmatthews.net> --------- Signed-off-by: Josh Matthews <josh@joshmatthews.net> | ||||
* | More files with CanGc fixes (#33892) | chickenleaf | 2024-10-18 | 1 | -2/+2 |
| | | | | | | | | | | | | | * More files with CanGc fixes Signed-off-by: L Ashwin B <lashwinib@gmail.com> * removed the can_gc inside !task Signed-off-by: L Ashwin B <lashwinib@gmail.com> --------- Signed-off-by: L Ashwin B <lashwinib@gmail.com> | ||||
* | script: Include constructors and static methods in generated DOM traits (#33665) | Josh Matthews | 2024-10-08 | 1 | -8/+7 |
| | | | | | | | | | | | | | | | | | * Add all constructors, special operations, and static methods to generated DOM interface traits. Signed-off-by: Josh Matthews <josh@joshmatthews.net> * Move all constructors and static methods defined in bare impl blocks inside FooMethods trait impls. Signed-off-by: Josh Matthews <josh@joshmatthews.net> * Add missing doc links. Signed-off-by: Josh Matthews <josh@joshmatthews.net> --------- Signed-off-by: Josh Matthews <josh@joshmatthews.net> | ||||
* | Start marking functions that can transitively trigger a GC (#33144) | Josh Matthews | 2024-08-22 | 1 | -3/+11 |
| | | | | | | | | | | | | | | | | | * Mark JS reflector wrappers as CanGc. Signed-off-by: Josh Matthews <josh@joshmatthews.net> * Propagate CanGc from reflect_dom_object_with_proto. Signed-off-by: Josh Matthews <josh@joshmatthews.net> * Mark DOM constructors as GC operations. Signed-off-by: Josh Matthews <josh@joshmatthews.net> --------- Signed-off-by: Josh Matthews <josh@joshmatthews.net> | ||||
* | clippy: Fix `redundant_*` warnings (#32056) | eri | 2024-04-11 | 1 | -16/+16 |
| | | | | | | | * clippy: Fix `redundant_field_names` warnings * clippy: Fix other `redundant_*` warnings * docs: Update docstring comments | ||||
* | clippy: Fix more clippy warnings in `components/scripts/dom` (#31914) | Rosemary Ajayi | 2024-03-28 | 1 | -1/+1 |
| | | | | | * refrence to a reference * refrence to a reference | ||||
* | clippy: Fix dereferencing a tuple pattern warnings (#31811) | Oluwatobi Sofela | 2024-03-21 | 1 | -9/+7 |
| | |||||
* | Strict import formatting (grouping and granularity) (#30325) | Samson | 2023-09-11 | 1 | -3/+4 |
| | | | | | * strict imports formatting * Reformat all imports | ||||
* | Rename reflect_dom_object2. | Josh Matthews | 2023-05-31 | 1 | -2/+2 |
| | |||||
* | Formatting. | Josh Matthews | 2023-05-28 | 1 | -1/+5 |
| | |||||
* | Support arbitrary protos when wrapping DOM objects with constructors. | Josh Matthews | 2023-05-28 | 1 | -3/+9 |
| | |||||
* | Add value argument to URLSearchParams's has() and delete() | Veronika Bušů | 2023-05-11 | 1 | -4/+12 |
| | | | | | | This commit should fix #29725. Signed-off-by: Veronika Bušů <paricbat@email.cz> | ||||
* | Implement URLSearchParams's size | 2shiori17 | 2023-03-02 | 1 | -0/+5 |
| | | | | Signed-off-by: 2shiori17 <98276492+2shiori17@users.noreply.github.com> | ||||
* | Add trait DomObjectWrap to provide WRAP function | YUAN LYU | 2020-03-20 | 1 | -6/+1 |
| | |||||
* | Modify `script` to prevent further violations of snake_case | Kunal Mohan | 2020-01-18 | 1 | -0/+1 |
| | |||||
* | Support USVString as default value of a union argument | Kagami Sascha Rosylight | 2019-10-17 | 1 | -6/+5 |
| | |||||
* | Implement URLSearchParams.prototype.sort() | CYBAI | 2019-01-08 | 1 | -0/+11 |
| | |||||
* | Combine two `impl`s into one | CYBAI | 2019-01-08 | 1 | -2/+0 |
| | |||||
* | Construct URLSearchParams from array or object | CYBAI | 2018-12-26 | 1 | -9/+23 |
| | |||||
* | Remove leading question mark when constructing URLSearchParams | CYBAI | 2018-12-25 | 1 | -3/+11 |
| | |||||
* | Update MPL license to https (part 3) | Jan Andre Ikenmeyer | 2018-11-19 | 1 | -1/+1 |
| | |||||
* | Reorder imports | Pyfisch | 2018-11-06 | 1 | -1/+1 |
| | |||||
* | Format remaining files | Pyfisch | 2018-11-06 | 1 | -1/+2 |
| | |||||
* | `cargo fix --edition` | Simon Sapin | 2018-11-06 | 1 | -12/+12 |
| | |||||
* | Format script component | chansuke | 2018-09-19 | 1 | -19/+24 |
| | |||||
* | Use the url crate without its query_encoding feature | Simon Sapin | 2017-10-31 | 1 | -4/+2 |
| | |||||
* | Remove use of unstable box syntax. | Simon Sapin | 2017-10-16 | 1 | -1/+1 |
| | | | | | | | | | | | | | | | | | | | | http://www.robohornet.org gives a score of 101.36 on master, and 102.68 with this PR. The latter is slightly better, but probably within noise level. So it looks like this PR does not affect DOM performance. This is expected since `Box::new` is defined as: ```rust impl<T> Box<T> { #[inline(always)] pub fn new(x: T) -> Box<T> { box x } } ``` With inlining, it should compile to the same as box syntax. | ||||
* | Rename Root<T> to DomRoot<T> | Anthony Ramine | 2017-09-26 | 1 | -3/+3 |
| | | | | | | | In a later PR, DomRoot<T> will become a type alias of Root<Dom<T>>, where Root<T> will be able to handle all the things that need to be rooted that have a stable traceable address that doesn't move for the whole lifetime of the root. Stay tuned. | ||||
* | Rename DOMRefCell<T> to DomRefCell<T> | Anthony Ramine | 2017-09-26 | 1 | -3/+3 |
| | | | | | | | | I don't want to do such a gratuitous rename, but with all the other types now having "Dom" as part of their name, and especially with "DomOnceCell", I feel like the other cell type that we already have should also follow the convention. That argument loses weight though when we realise there is still DOMString and other things. | ||||
* | Rename dom::bindings::js to dom::bindings::root | Anthony Ramine | 2017-09-26 | 1 | -1/+1 |
| | |||||
* | Make #[dom_struct] a proc_macro attribute | Anthony Ramine | 2017-02-24 | 1 | -0/+1 |
| | |||||
* | Make URLSearchParams iterable. | yoyo930021 | 2016-10-07 | 1 | -2/+23 |
| | | | | | Fixes #13022. Fixes #13077. | ||||
* | Pass a &GlobalScope to WebIDL static methods and constructors | Anthony Ramine | 2016-10-06 | 1 | -3/+2 |
| | |||||
* | Make reflect_dom_object take a &GlobalScope | Anthony Ramine | 2016-10-06 | 1 | -2/+3 |
| | |||||
* | Move DOMString back to script | Anthony Ramine | 2016-05-24 | 1 | -2/+1 |
| | | | | This entirely removes the 'non-geckolib' feature of the util crate. | ||||
* | Correctly initialize URL.searchParams | Simon Sapin | 2016-04-23 | 1 | -19/+21 |
| | |||||
* | Upgrade to rust-url 1.0 and hyper 0.9 | Simon Sapin | 2016-04-23 | 1 | -4/+8 |
| | |||||
* | Implement URL.searchParams | Stjepan Glavina | 2016-04-05 | 1 | -7/+20 |
| | | | | Spec: https://url.spec.whatwg.org/#dom-url-searchparams | ||||
* | Fix #9508: Beautify our union enums constructors | Alexander Lopatin | 2016-02-07 | 1 | -3/+2 |
| | |||||
* | Improved .find().map() | Florian Strübe | 2016-01-27 | 1 | -1/+2 |
| | |||||
* | Use .find().map() instead of .filter_map().next() in URLSearchParams::Get | Florian Strübe | 2016-01-26 | 1 | -7/+1 |
| | |||||
* | Implement URLSearchParams::getAll | Fernando Martins | 2016-01-15 | 1 | -0/+12 |
| | |||||
* | Replaced DOMString constructor by conversion functions. | Alan Jeffrey | 2015-11-12 | 1 | -1/+1 |
| | | | | | | Replaced DOMString(...) by DOMString::from(...). Replaced ....0 by String::from(...). Removed any uses of .to_owner() in DOMString::from("..."). | ||||
* | Make DOMString a newtype around String, rather than a typedef. | Ms2ger | 2015-11-04 | 1 | -1/+1 |
| | | | | | | | | | | This should make it somewhat easier to experiment with alternative representations in the future. To reduce churn, this commit leaves the String field public, though. Also, this will allow us to use the default String type to represent the IDL USVString type, which explicitly forbids unpaired surrogates, ans as such is a better match to the Rust String type. | ||||
* | Get rid of a bunch of explicit derefs | David Zbarsky | 2015-11-03 | 1 | -2/+2 |
| | |||||
* | make test-tidy happy + fix some merge errors | rohan.prinja | 2015-11-03 | 1 | -1/+1 |
| | |||||
* | merge from master | rohan.prinja | 2015-11-03 | 1 | -21/+22 |
|\ | |||||
| * | Update URLSearchParams to use USVString and String. | Ms2ger | 2015-10-30 | 1 | -21/+22 |
| | | | | | | | | This matches the specification. | ||||
* | | more refactoring | rohan.prinja | 2015-10-30 | 1 | -1/+1 |
|/ | |||||
* | sorted the extern crate, mod & use declarations | Ravi Shankar | 2015-09-24 | 1 | -1/+1 |
| |