aboutsummaryrefslogtreecommitdiffstats
path: root/components/script/dom/testbinding.rs
Commit message (Collapse)AuthorAgeFilesLines
...
* Add trait DomObjectWrap to provide WRAP functionYUAN LYU2020-03-201-6/+2
|
* Always pass InRealm to GlobalScope::from_context to avoid getting null globalCYBAI2020-02-161-2/+5
|
* rename compartment to realmKunal Mohan2020-01-241-5/+5
|
* Modify `script` to prevent further violations of snake_caseKunal Mohan2020-01-181-0/+2
|
* re-structure blob, structured serializationGregory Terzian2019-12-111-11/+7
|
* Support WebIDL `record<>`Kagami Sascha Rosylight2019-10-151-33/+47
|
* Use safe JSContext when possible in interface.rsmarmeladema2019-08-091-3/+2
|
* Remove some usage of unsafe code in Promisemarmeladema2019-08-091-12/+4
|
* Convert CGTraitInterface to use safe JSContext instead of raw JSContextmarmeladema2019-07-241-75/+48
|
* Change bindings generation to make Exposed annotation aware of ↵sreeise2019-07-141-0/+12
| | | | members/partial interfaces
* Use the newly added inCompartments option everywhere it can beBastien Orivel2019-05-251-10/+4
|
* Add support for attributes to the inCompartments binding parameterBastien Orivel2019-05-251-3/+2
|
* Pass InCompartment by valueAron Zwaan2019-04-251-2/+2
|
* Add proof parameter to Promise::new_in_current_compartmentAron Zwaan2019-04-241-4/+11
|
* Rename Promise::new to Promise::new_in_current_compartmentAron Zwaan2019-04-031-2/+4
|
* #8539 Config preferences backend restructurePeter Hall2019-03-201-4/+7
|
* Remove now-unnecessary must_root and allow(unrooted_must_root) annotationsManish Goregaokar2019-01-041-2/+0
|
* Update MPL license to https (part 3)Jan Andre Ikenmeyer2018-11-191-1/+1
|
* `cargo fix --edition-idioms`Simon Sapin2018-11-081-1/+1
|
* Reorder importsPyfisch2018-11-061-10/+24
|
* Sort `use` statementsSimon Sapin2018-11-061-3/+4
|
* `cargo fix --edition`Simon Sapin2018-11-061-30/+30
|
* Handle default empty sequence valuesKeith Yeung2018-11-011-0/+2
|
* Format script componentchansuke2018-09-191-143/+414
|
* Adapt Servo for mozjs 0.6 and the changes introduced in servo/rust-mozjs#393Marcin Mielniczuk2018-03-281-1/+2
|
* Add codegen test for function overloads taking typed array argsIgor Matuszewski2018-03-231-0/+3
|
* Root `any` members in dictionariesIgor Matuszewski2018-03-161-2/+2
|
* Root JS object members in dictionariesIgor Matuszewski2018-03-161-1/+1
|
* Support nullable typed arrays in codegenIgor Matuszewski2018-03-141-0/+1
|
* WIP: Accept typed array arguments in codegenIgor Matuszewski2018-03-141-0/+5
|
* Add WPT test for WebIDL union conversion containing object valuesIgor Matuszewski2018-03-131-0/+8
|
* Use safe NonZero constructor instead of an explicit null checkSimon Sapin2018-01-221-4/+2
|
* Replace NonNullJSObjectPtr with std::ptr::NonNull<JSObject>Simon Sapin2018-01-221-8/+8
|
* Root sequence<{any,object}> IDL arguments using CustomAutoRooterIgor Matuszewski2018-01-051-0/+9
| | | | Also pulls in mozjs 0.1.10 to support the change.
* Fix binding generation for overloaded functions with optionals and default ↵Fernando Jiménez Moreno2017-11-111-0/+2
| | | | values
* Import sequence inner types if it appears in dictionary membersKeith Yeung2017-11-081-0/+1
|
* Replace all uses of the `heapsize` crate with `malloc_size_of`.Nicholas Nethercote2017-10-181-4/+4
| | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | Servo currently uses `heapsize`, but Stylo/Gecko use `malloc_size_of`. `malloc_size_of` is better -- it handles various cases that `heapsize` does not -- so this patch changes Servo to use `malloc_size_of`. This patch makes the following changes to the `malloc_size_of` crate. - Adds `MallocSizeOf` trait implementations for numerous types, some built-in (e.g. `VecDeque`), some external and Servo-only (e.g. `string_cache`). - Makes `enclosing_size_of_op` optional, because vanilla jemalloc doesn't support that operation. - For `HashSet`/`HashMap`, falls back to a computed estimate when `enclosing_size_of_op` isn't available. - Adds an extern "C" `malloc_size_of` function that does the actual heap measurement; this is based on the same functions from the `heapsize` crate. This patch makes the following changes elsewhere. - Converts all the uses of `heapsize` to instead use `malloc_size_of`. - Disables the "heapsize"/"heap_size" feature for the external crates that provide it. - Removes the `HeapSizeOf` implementation from `hashglobe`. - Adds `ignore` annotations to a few `Rc`/`Arc`, because `malloc_size_of` doesn't derive those types, unlike `heapsize`.
* Replace NonZero<*mut JSObject> with a wrapper to enable local trait impls.Simon Sapin2017-10-161-8/+8
|
* Remove use of unstable box syntax.Simon Sapin2017-10-161-2/+2
| | | | | | | | | | | | | | | | | | | | http://www.robohornet.org gives a score of 101.36 on master, and 102.68 with this PR. The latter is slightly better, but probably within noise level. So it looks like this PR does not affect DOM performance. This is expected since `Box::new` is defined as: ```rust impl<T> Box<T> { #[inline(always)] pub fn new(x: T) -> Box<T> { box x } } ``` With inlining, it should compile to the same as box syntax.
* Rename Root<T> to DomRoot<T>Anthony Ramine2017-09-261-20/+20
| | | | | | | In a later PR, DomRoot<T> will become a type alias of Root<Dom<T>>, where Root<T> will be able to handle all the things that need to be rooted that have a stable traceable address that doesn't move for the whole lifetime of the root. Stay tuned.
* Rename dom::bindings::js to dom::bindings::rootAnthony Ramine2017-09-261-1/+1
|
* Remove almost all uses of Heap::new.Josh Matthews2017-09-251-3/+3
|
* Store rootable dictionary members of dictionaries in RootedTraceableBox.Josh Matthews2017-09-251-2/+2
|
* Be more conservative about safety of dictionary and union values.Josh Matthews2017-09-251-5/+5
| | | | | | | | Mark dictionaries containing GC values as must_root, and wrap them in RootedTraceableBox in automatically-generated APIs. To accommodate union variants that are now flagged as unsafe, add RootedTraceableBox to union variants that need to be rooted, rather than wrapping the entire union value.
* Make Promise::reject_error soundAnthony Ramine2017-09-221-1/+1
|
* Make Promise::resolve_native actually soundAnthony Ramine2017-09-211-5/+2
| | | | | We shouldn't have to pass a raw JSContext pointer, and to enter the promise's context's compartment by hand.
* Rename a couple of Promise methodsAnthony Ramine2017-09-211-2/+2
|
* order derivable traits listsClément DAVID2017-08-231-2/+2
| | | | | | Ignoring : - **generated**.rs - python/tidy/servo_tidy_tests/rust_tidy.rs
* Upgrade to rustc 1.21.0-nightly (599be0d18 2017-07-26)Simon Sapin2017-07-271-2/+2
|
* Update the WebIDL parserAnthony Ramine2017-06-091-6/+3
|