aboutsummaryrefslogtreecommitdiffstats
path: root/components/script/dom/navigator.rs
Commit message (Collapse)AuthorAgeFilesLines
* Fix media session action handlingFernando Jiménez Moreno2019-11-201-10/+2
|
* Move active media session logic to constellationFernando Jiménez Moreno2019-11-201-2/+2
|
* Register media instance with session and prepare communication with embedderFernando Jiménez Moreno2019-11-201-2/+20
|
* MediaSession API DOM bindingsFernando Jiménez Moreno2019-11-201-0/+9
|
* Script: removed a few opts::get()oneturkmen2019-06-261-1/+1
|
* Added missing NavigatorId attributesAlan Jeffrey2019-06-111-0/+15
|
* Use the newly added inCompartments option everywhere it can beBastien Orivel2019-05-251-7/+3
|
* Pass InCompartment by valueAron Zwaan2019-04-251-1/+1
|
* Add proof parameter to Promise::new_in_current_compartmentAron Zwaan2019-04-241-2/+6
|
* Rename Promise::new to Promise::new_in_current_compartmentAron Zwaan2019-04-031-1/+2
|
* Add MediaDevices::GetUserMediaManish Goregaokar2019-01-291-1/+2
|
* Add Navigator::MediaDevicesManish Goregaokar2019-01-291-0/+8
|
* Remove now-unnecessary must_root and allow(unrooted_must_root) annotationsManish Goregaokar2019-01-041-1/+0
|
* Add spec linksManish Goregaokar2018-12-221-0/+1
|
* Fill in XR frame/pose/view implementationsManish Goregaokar2018-12-211-1/+1
|
* Fill in XR.requestSessionManish Goregaokar2018-12-191-1/+8
|
* Move VR interface to XRManish Goregaokar2018-12-191-10/+7
| | | | The WebVR spec no longer has a navigator.vr, but there is a navigator.XR in the XR spec. Instead of duplicating work I've combined the two.
* Update MPL license to https (part 3)Jan Andre Ikenmeyer2018-11-191-1/+1
|
* Reorder importsPyfisch2018-11-061-1/+1
|
* `cargo fix --edition`Simon Sapin2018-11-061-16/+16
|
* Format script componentchansuke2018-09-191-11/+14
|
* Remove use of unstable box syntax.Simon Sapin2017-10-161-1/+1
| | | | | | | | | | | | | | | | | | | | http://www.robohornet.org gives a score of 101.36 on master, and 102.68 with this PR. The latter is slightly better, but probably within noise level. So it looks like this PR does not affect DOM performance. This is expected since `Box::new` is defined as: ```rust impl<T> Box<T> { #[inline(always)] pub fn new(x: T) -> Box<T> { box x } } ``` With inlining, it should compile to the same as box syntax.
* Rename Root<T> to DomRoot<T>Anthony Ramine2017-09-261-9/+9
| | | | | | | In a later PR, DomRoot<T> will become a type alias of Root<Dom<T>>, where Root<T> will be able to handle all the things that need to be rooted that have a stable traceable address that doesn't move for the whole lifetime of the root. Stay tuned.
* Rename MutNullableJS<T> to MutNullableDom<T>Anthony Ramine2017-09-261-8/+8
|
* Rename dom::bindings::js to dom::bindings::rootAnthony Ramine2017-09-261-1/+1
|
* WebVR 1.1 spec compatibilityImanol Fernandez2017-07-051-6/+15
|
* Implement Gamepad APIImanol Fernandez2017-04-121-8/+14
|
* Make #[dom_struct] a proc_macro attributeAnthony Ramine2017-02-241-0/+1
|
* Permission APIAttila Dusnoki2017-02-131-1/+9
|
* WebVR API Implementation, r=larsbergstromImanol Fernandez2017-01-091-0/+16
|
* Remove HeapGCValueAnthony Ramine2016-12-121-5/+5
| | | | | | It could be used to have mutable JSVal fields without GC barriers. With the removal of that trait, MutHeap and MutNullableHeap can respectively be replaced by MutJS and MutNullableJS.
* Rename `Reflectable` to `DomObject`.Corey Farwell2016-12-081-1/+1
| | | | Fixes https://github.com/servo/servo/issues/8473.
* Rename Reflectable::global_scope to globalAnthony Ramine2016-10-061-4/+4
|
* Introduce Reflectable::global_scopeAnthony Ramine2016-10-061-4/+4
|
* Make reflect_dom_object take a &GlobalScopeAnthony Ramine2016-10-061-6/+7
|
* Replace instances of old ServiceWorker specification URL with new oneVignesh Sarma K (വിഘ്നേഷ് ശ൪മ കെ)2016-09-251-1/+1
| | | | | | The old specification URL is https://slightlyoff.github.io/ServiceWorker/spec/service_worker/ has been replaced by the new one at https://w3c.github.io/ServiceWorker/.
* Most of the code refactoring needed to be done is done with this commit.Arthur Marble2016-09-181-3/+3
|
* Implemented Navigator.cookieEnabledAshwin R2016-09-011-0/+6
|
* implement related sw interface and register methodRahul Sharma2016-06-021-0/+8
|
* Move DOMString back to scriptAnthony Ramine2016-05-241-1/+1
| | | | This entirely removes the 'non-geckolib' feature of the util crate.
* Implemented stub for NavigatorPluginsConnor Brewster2016-04-111-0/+21
|
* implements NavigatorLanguageRahul Sharma2016-03-171-0/+5
|
* WebBluetooth API classesAttila Dusnoki2016-03-161-3/+11
|
* more refactoringrohan.prinja2015-10-301-1/+1
|
* Make the traits for the IDL interfaces take &selfAnthony Ramine2015-08-271-8/+8
|
* make dom_struct derive HeapSizeOf,João Oliveira2015-08-271-2/+0
| | | | closes #7357
* Measure heap memory usage for more types. Fixes #6951Bogdan Cuza2015-08-131-0/+1
|
* Add spec linksBogdan Cuza2015-07-281-0/+7
|
* Upgrade to SM 39Michael Wu2015-06-191-3/+3
|
* Implement Navigator.appVersion(#5409)Deokjin Kim2015-04-011-0/+4
|