aboutsummaryrefslogtreecommitdiffstats
path: root/components/script/dom/htmlcanvaselement.rs
Commit message (Collapse)AuthorAgeFilesLines
* Use `#![register_tool]` instead of `#![register_attr]`Simon Sapin2019-11-151-1/+1
| | | | CC https://github.com/rust-lang/rust/issues/66079
* Addresses issues raised in #24465; removes redundancy in set_bitmap_dimensionsBailey Blankenship2019-11-101-1/+4
| | | | Removed passing test .ini files and moved euclid extensions to euclidext.rs to factor out redundant code
* Support CORS attributes for image elements.Josh Matthews2019-10-041-1/+7
|
* Double key image cache by requesting origin, and store CORS status with ↵Josh Matthews2019-10-041-0/+1
| | | | cached images.
* Remove some usage of unsafe code in HTMLCanvasElementmarmeladema2019-08-091-33/+26
|
* Convert CGTraitInterface to use safe JSContext instead of raw JSContextmarmeladema2019-07-241-11/+12
|
* Convert internal methods to handle safe JSContext instead of raw JSContextmarmeladema2019-07-241-1/+2
|
* Update euclid.Emilio Cobos Álvarez2019-07-231-1/+1
| | | | | | | | There are a few canvas2d-related dependencies that haven't updated, but they only use euclid internally so that's not blocking landing the rest of the changes. Given the size of this patch, I think it's useful to get this landed as-is.
* #8539 Config preferences backend restructurePeter Hall2019-03-201-2/+2
|
* Remove offscreen_gl_context dependency from canvas_traits and script.Josh Matthews2019-03-071-2/+1
|
* Rustfmt has changed its default style :/Simon Sapin2018-12-281-3/+3
|
* Make HTMLCanvasElement::fetch_all_data return a shared memory blobAnthony Ramine2018-11-211-3/+4
|
* Update MPL license to https (part 3)Jan Andre Ikenmeyer2018-11-191-1/+1
|
* Remove useless `use crate_name;` imports.Simon Sapin2018-11-081-1/+0
| | | | A `crate_name::foo` path always works in 2018
* `cargo fix --edition-idioms`Simon Sapin2018-11-081-2/+2
|
* Reorder importsPyfisch2018-11-061-7/+13
|
* Format remaining filesPyfisch2018-11-061-1/+1
|
* `cargo fix --edition`Simon Sapin2018-11-061-21/+21
|
* Share some code between 2D canvas and WebGLAnthony Ramine2018-10-091-2/+2
|
* Add a couple of bug linksAnthony Ramine2018-10-081-0/+2
|
* Avoid ctx.getImageData in canvas.toDataURLAnthony Ramine2018-10-081-10/+6
|
* Align ctx.createImageData and ctx.getImageData with the specAnthony Ramine2018-10-061-8/+1
|
* Avoid copying pixels in ctx.putImageData sometimesAnthony Ramine2018-10-061-1/+2
|
* Reindent the WebGL 2 case of canvas.toDataURLAnthony Ramine2018-10-031-6/+5
|
* Slightly clean up the final URL creation in canvas.toDataURLAnthony Ramine2018-10-031-13/+10
|
* Make HTMLCanvasElement::get_size return a Size2D<u32>Anthony Ramine2018-10-021-3/+3
| | | | The changes keep trickling down.
* Format script componentchansuke2018-09-191-56/+78
|
* Don't create 2D canvas contexts arbitrarilyAnthony Ramine2018-09-161-40/+39
| | | | | Sometimes, the canvas still has no rendering context, in this case it represents a transparent black rectangle.
* Mark some canvas methods as unsafeAnthony Ramine2018-09-161-5/+10
| | | | They use raw JS context pointers.
* Update HTMLCanvasElement WebIDL definitionAnthony Ramine2018-09-151-28/+27
|
* Add unique canvas IDs to all canvas operations.Brody Eastwood2018-04-021-2/+16
|
* Adapt Servo for mozjs 0.6 and the changes introduced in servo/rust-mozjs#393Marcin Mielniczuk2018-03-281-1/+2
|
* Use ByteBuf for the canvas messagesAnthony Ramine2018-03-261-1/+1
| | | | | The type Vec<u8> is super unefficient to work with in Serde if all you want to represent is a simple blob.
* Implement HTMLCanvasElement.toDataURL for WebGL canvas (fixes #19147)Anthony Ramine2018-03-231-1/+12
|
* Implements profiler for blocked recvNakul Jindal2018-03-221-2/+3
|
* Kick off WebGL 2.0 implementationImanol Fernandez2017-10-271-28/+79
|
* Use try syntax for Option where appropriateMatt Brubeck2017-10-201-6/+1
|
* Replace all uses of the `heapsize` crate with `malloc_size_of`.Nicholas Nethercote2017-10-181-1/+1
| | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | Servo currently uses `heapsize`, but Stylo/Gecko use `malloc_size_of`. `malloc_size_of` is better -- it handles various cases that `heapsize` does not -- so this patch changes Servo to use `malloc_size_of`. This patch makes the following changes to the `malloc_size_of` crate. - Adds `MallocSizeOf` trait implementations for numerous types, some built-in (e.g. `VecDeque`), some external and Servo-only (e.g. `string_cache`). - Makes `enclosing_size_of_op` optional, because vanilla jemalloc doesn't support that operation. - For `HashSet`/`HashMap`, falls back to a computed estimate when `enclosing_size_of_op` isn't available. - Adds an extern "C" `malloc_size_of` function that does the actual heap measurement; this is based on the same functions from the `heapsize` crate. This patch makes the following changes elsewhere. - Converts all the uses of `heapsize` to instead use `malloc_size_of`. - Disables the "heapsize"/"heap_size" feature for the external crates that provide it. - Removes the `HeapSizeOf` implementation from `hashglobe`. - Adds `ignore` annotations to a few `Rc`/`Arc`, because `malloc_size_of` doesn't derive those types, unlike `heapsize`.
* Remove use of unstable box syntax.Simon Sapin2017-10-161-1/+1
| | | | | | | | | | | | | | | | | | | | http://www.robohornet.org gives a score of 101.36 on master, and 102.68 with this PR. The latter is slightly better, but probably within noise level. So it looks like this PR does not affect DOM performance. This is expected since `Box::new` is defined as: ```rust impl<T> Box<T> { #[inline(always)] pub fn new(x: T) -> Box<T> { box x } } ``` With inlining, it should compile to the same as box syntax.
* Rename Root<T> to DomRoot<T>Anthony Ramine2017-09-261-6/+6
| | | | | | | In a later PR, DomRoot<T> will become a type alias of Root<Dom<T>>, where Root<T> will be able to handle all the things that need to be rooted that have a stable traceable address that doesn't move for the whole lifetime of the root. Stay tuned.
* Rename DOMRefCell<T> to DomRefCell<T>Anthony Ramine2017-09-261-3/+3
| | | | | | | | I don't want to do such a gratuitous rename, but with all the other types now having "Dom" as part of their name, and especially with "DomOnceCell", I feel like the other cell type that we already have should also follow the convention. That argument loses weight though when we realise there is still DOMString and other things.
* Rename LayoutJS<T> to LayoutDom<T>Anthony Ramine2017-09-261-2/+2
|
* Rename JS<T> to Dom<T>Anthony Ramine2017-09-261-5/+5
|
* Rename dom::bindings::js to dom::bindings::rootAnthony Ramine2017-09-261-1/+1
|
* order derivable traits listsClément DAVID2017-08-231-1/+1
| | | | | | Ignoring : - **generated**.rs - python/tidy/servo_tidy_tests/rust_tidy.rs
* Revert "Auto merge of #18114 - emilio:revert-webgl-refactor, r=nox"Anthony Ramine2017-08-161-35/+31
| | | | | This reverts commit 4d10d39e8fe841c5fe2ac58da2daaa13c10c140e, reversing changes made to ee94e2b7c0bd327abe8f9545b2a1f792f67a2bdd.
* Revert "Auto merge of #17891 - MortimerGoro:webgl_move, r=glennw,emilio"Emilio Cobos Álvarez2017-08-161-31/+35
| | | | | This reverts commit 90f55ea4580e2a15f7d70d0491444f18b972d450, reversing changes made to 2e60b27a2186a8cba4b952960155dfcf3f47d7db.
* Improve WebGL architecture.Imanol Fernandez2017-08-151-35/+31
|
* Untry scriptSimon Sapin2017-06-181-2/+2
|
* Bump euclid to 0.14.Nicolas Silva2017-06-141-1/+1
|