Commit message (Collapse) | Author | Age | Files | Lines | |
---|---|---|---|---|---|
* | Strict import formatting (grouping and granularity) (#30325) | Samson | 2023-09-11 | 1 | -12/+13 |
| | | | | | * strict imports formatting * Reformat all imports | ||||
* | bump base64 from 0.10 to 0.21 (#29804) | Tuna | 2023-08-02 | 1 | -2/+2 |
| | | | | | | | | | * bump base64 from 0.10 to 0.21 * Fix configuration of bitflags --------- Co-authored-by: Martin Robinson <mrobinson@igalia.com> | ||||
* | Rename reflect_dom_object2. | Josh Matthews | 2023-05-31 | 1 | -2/+2 |
| | |||||
* | Formatting. | Josh Matthews | 2023-05-28 | 1 | -1/+4 |
| | |||||
* | Support arbitrary protos when wrapping DOM objects with constructors. | Josh Matthews | 2023-05-28 | 1 | -5/+6 |
| | |||||
* | Make GlobalScope.get_cx a static method. | Josh Matthews | 2023-05-20 | 1 | -1/+1 |
| | |||||
* | Add trait DomObjectWrap to provide WRAP function | YUAN LYU | 2020-03-20 | 1 | -6/+2 |
| | |||||
* | rename compartment to realm | Kunal Mohan | 2020-01-24 | 1 | -1/+1 |
| | |||||
* | Modify `script` to prevent further violations of snake_case | Kunal Mohan | 2020-01-18 | 1 | -0/+1 |
| | |||||
* | remove unnecessary thread in filereader, add stream TODO | Gregory Terzian | 2019-12-10 | 1 | -44/+25 |
| | |||||
* | don't send progress event for empty blob | Siddhartha Mishra | 2019-10-10 | 1 | -2/+4 |
| | |||||
* | FileReader.read sets `result` to null before performing read operation | Micah Tigley | 2019-09-30 | 1 | -2/+5 |
| | |||||
* | Remove some usage of unsafe code in FileReader | marmeladema | 2019-08-09 | 1 | -8/+6 |
| | |||||
* | Modify *::get_cx methods to return a safe JSContext instead of a raw one | marmeladema | 2019-07-24 | 1 | -1/+1 |
| | |||||
* | Convert CGTraitInterface to use safe JSContext instead of raw JSContext | marmeladema | 2019-07-24 | 1 | -2/+5 |
| | |||||
* | Create a helper API for entering a DOM object's compartment | Kamil Niski | 2019-06-29 | 1 | -2/+2 |
| | | | | | | Revert some unnecessary changes Fix fmt errors | ||||
* | Update to SpiderMonkey 66. | Josh Matthews | 2019-05-10 | 1 | -3/+2 |
| | |||||
* | Remove mozjs dep from malloc_size_of. | Josh Matthews | 2019-05-02 | 1 | -1/+1 |
| | |||||
* | Rustfmt has changed its default style :/ | Simon Sapin | 2018-12-28 | 1 | -1/+1 |
| | |||||
* | Update MPL license to https (part 3) | Jan Andre Ikenmeyer | 2018-11-19 | 1 | -1/+1 |
| | |||||
* | Reorder imports | Pyfisch | 2018-11-06 | 1 | -3/+5 |
| | |||||
* | Format remaining files | Pyfisch | 2018-11-06 | 1 | -1/+2 |
| | |||||
* | Sort `use` statements | Simon Sapin | 2018-11-06 | 1 | -3/+3 |
| | |||||
* | `cargo fix --edition` | Simon Sapin | 2018-11-06 | 1 | -20/+20 |
| | |||||
* | Update hyper to 0.12 | Bastien Orivel | 2018-11-01 | 1 | -6/+5 |
| | |||||
* | Format script component | chansuke | 2018-09-19 | 1 | -2/+1 |
| | |||||
* | introduce "per task source" ignoring of tasks | Gregory Terzian | 2018-07-10 | 1 | -2/+2 |
| | |||||
* | Implement read methods on FileReaderSync | Jonas Reinwald | 2018-06-04 | 1 | -69/+139 |
| | |||||
* | Fix tyvar_behind_raw_pointer warnings | Simon Sapin | 2018-01-10 | 1 | -1/+2 |
| | | | | https://github.com/rust-lang/rust/issues/46906 | ||||
* | Replace rust-encoding with encoding-rs | Simon Sapin | 2017-11-01 | 1 | -8/+6 |
| | |||||
* | Replace all uses of the `heapsize` crate with `malloc_size_of`. | Nicholas Nethercote | 2017-10-18 | 1 | -5/+5 |
| | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | Servo currently uses `heapsize`, but Stylo/Gecko use `malloc_size_of`. `malloc_size_of` is better -- it handles various cases that `heapsize` does not -- so this patch changes Servo to use `malloc_size_of`. This patch makes the following changes to the `malloc_size_of` crate. - Adds `MallocSizeOf` trait implementations for numerous types, some built-in (e.g. `VecDeque`), some external and Servo-only (e.g. `string_cache`). - Makes `enclosing_size_of_op` optional, because vanilla jemalloc doesn't support that operation. - For `HashSet`/`HashMap`, falls back to a computed estimate when `enclosing_size_of_op` isn't available. - Adds an extern "C" `malloc_size_of` function that does the actual heap measurement; this is based on the same functions from the `heapsize` crate. This patch makes the following changes elsewhere. - Converts all the uses of `heapsize` to instead use `malloc_size_of`. - Disables the "heapsize"/"heap_size" feature for the external crates that provide it. - Removes the `HeapSizeOf` implementation from `hashglobe`. - Adds `ignore` annotations to a few `Rc`/`Arc`, because `malloc_size_of` doesn't derive those types, unlike `heapsize`. | ||||
* | Remove use of unstable box syntax. | Simon Sapin | 2017-10-16 | 1 | -1/+1 |
| | | | | | | | | | | | | | | | | | | | | http://www.robohornet.org gives a score of 101.36 on master, and 102.68 with this PR. The latter is slightly better, but probably within noise level. So it looks like this PR does not affect DOM performance. This is expected since `Box::new` is defined as: ```rust impl<T> Box<T> { #[inline(always)] pub fn new(x: T) -> Box<T> { box x } } ``` With inlining, it should compile to the same as box syntax. | ||||
* | Rename Root<T> to DomRoot<T> | Anthony Ramine | 2017-09-26 | 1 | -4/+4 |
| | | | | | | | In a later PR, DomRoot<T> will become a type alias of Root<Dom<T>>, where Root<T> will be able to handle all the things that need to be rooted that have a stable traceable address that doesn't move for the whole lifetime of the root. Stay tuned. | ||||
* | Rename DOMRefCell<T> to DomRefCell<T> | Anthony Ramine | 2017-09-26 | 1 | -6/+6 |
| | | | | | | | | I don't want to do such a gratuitous rename, but with all the other types now having "Dom" as part of their name, and especially with "DomOnceCell", I feel like the other cell type that we already have should also follow the convention. That argument loses weight though when we realise there is still DOMString and other things. | ||||
* | Rename MutNullableJS<T> to MutNullableDom<T> | Anthony Ramine | 2017-09-26 | 1 | -3/+3 |
| | |||||
* | Rename dom::bindings::js to dom::bindings::root | Anthony Ramine | 2017-09-26 | 1 | -1/+1 |
| | |||||
* | Remove almost all uses of Heap::new. | Josh Matthews | 2017-09-25 | 1 | -2/+3 |
| | |||||
* | Be more conservative about safety of dictionary and union values. | Josh Matthews | 2017-09-25 | 1 | -1/+3 |
| | | | | | | | | Mark dictionaries containing GC values as must_root, and wrap them in RootedTraceableBox in automatically-generated APIs. To accommodate union variants that are now flagged as unsafe, add RootedTraceableBox to union variants that need to be rooted, rather than wrapping the entire union value. | ||||
* | Introduce TaskOnce | Anthony Ramine | 2017-09-20 | 1 | -3/+3 |
| | | | | | Having both TaskBox and TaskOnce allows us to remove the superfluous inner boxing from CancellableTask<T>. | ||||
* | Move Task to its own module | Anthony Ramine | 2017-09-18 | 1 | -1/+1 |
| | |||||
* | Remove FileReadingRunnable | Anthony Ramine | 2017-09-16 | 1 | -7/+7 |
| | |||||
* | Rename Runnable to Task | Anthony Ramine | 2017-09-16 | 1 | -12/+21 |
| | | | | | | | | | | | | The changes are: * `*Runnable` -> `*Task`; * `RunnableMsg` -> `Task`; * `RunnableWrapper` -> `TaskCanceller`; * `MainThreadRunnable` -> `MainThreadTask`; * `wrap_runnable` -> `wrap_task`; * `get_runnable_wrapper` -> `task_canceller`; * `handler` -> `run`; * `main_thread_handler` -> `run_with_script_thread`. | ||||
* | Use absolute paths in the event handlers macros | Anthony Ramine | 2017-09-01 | 1 | -1/+0 |
| | |||||
* | order derivable traits lists | Clément DAVID | 2017-08-23 | 1 | -3/+3 |
| | | | | | | Ignoring : - **generated**.rs - python/tidy/servo_tidy_tests/rust_tidy.rs | ||||
* | Replace use of rustc_serialize::base64 by base64 | Anthony Ramine | 2017-03-26 | 1 | -8/+2 |
| | |||||
* | Remove support for Blob::{close, isClosed} | Charles Vandevoorde | 2017-02-28 | 1 | -11/+2 |
| | |||||
* | Make #[dom_struct] a proc_macro attribute | Anthony Ramine | 2017-02-24 | 1 | -0/+1 |
| | |||||
* | Use Heap for dictionary and union members. | Ms2ger | 2017-02-16 | 1 | -1/+1 |
| | |||||
* | Update js. | Ms2ger | 2017-02-15 | 1 | -2/+2 |
| | | | | Fixes #15553. | ||||
* | Use an ArrayBuffer to implement readAsArrayBuffer. | Ms2ger | 2017-01-19 | 1 | -2/+2 |
| |