aboutsummaryrefslogtreecommitdiffstats
path: root/components/script/dom/filereader.rs
Commit message (Collapse)AuthorAgeFilesLines
...
* Rename Root<T> to DomRoot<T>Anthony Ramine2017-09-261-4/+4
| | | | | | | In a later PR, DomRoot<T> will become a type alias of Root<Dom<T>>, where Root<T> will be able to handle all the things that need to be rooted that have a stable traceable address that doesn't move for the whole lifetime of the root. Stay tuned.
* Rename DOMRefCell<T> to DomRefCell<T>Anthony Ramine2017-09-261-6/+6
| | | | | | | | I don't want to do such a gratuitous rename, but with all the other types now having "Dom" as part of their name, and especially with "DomOnceCell", I feel like the other cell type that we already have should also follow the convention. That argument loses weight though when we realise there is still DOMString and other things.
* Rename MutNullableJS<T> to MutNullableDom<T>Anthony Ramine2017-09-261-3/+3
|
* Rename dom::bindings::js to dom::bindings::rootAnthony Ramine2017-09-261-1/+1
|
* Remove almost all uses of Heap::new.Josh Matthews2017-09-251-2/+3
|
* Be more conservative about safety of dictionary and union values.Josh Matthews2017-09-251-1/+3
| | | | | | | | Mark dictionaries containing GC values as must_root, and wrap them in RootedTraceableBox in automatically-generated APIs. To accommodate union variants that are now flagged as unsafe, add RootedTraceableBox to union variants that need to be rooted, rather than wrapping the entire union value.
* Introduce TaskOnceAnthony Ramine2017-09-201-3/+3
| | | | | Having both TaskBox and TaskOnce allows us to remove the superfluous inner boxing from CancellableTask<T>.
* Move Task to its own moduleAnthony Ramine2017-09-181-1/+1
|
* Remove FileReadingRunnableAnthony Ramine2017-09-161-7/+7
|
* Rename Runnable to TaskAnthony Ramine2017-09-161-12/+21
| | | | | | | | | | | | The changes are: * `*Runnable` -> `*Task`; * `RunnableMsg` -> `Task`; * `RunnableWrapper` -> `TaskCanceller`; * `MainThreadRunnable` -> `MainThreadTask`; * `wrap_runnable` -> `wrap_task`; * `get_runnable_wrapper` -> `task_canceller`; * `handler` -> `run`; * `main_thread_handler` -> `run_with_script_thread`.
* Use absolute paths in the event handlers macrosAnthony Ramine2017-09-011-1/+0
|
* order derivable traits listsClément DAVID2017-08-231-3/+3
| | | | | | Ignoring : - **generated**.rs - python/tidy/servo_tidy_tests/rust_tidy.rs
* Replace use of rustc_serialize::base64 by base64Anthony Ramine2017-03-261-8/+2
|
* Remove support for Blob::{close, isClosed}Charles Vandevoorde2017-02-281-11/+2
|
* Make #[dom_struct] a proc_macro attributeAnthony Ramine2017-02-241-0/+1
|
* Use Heap for dictionary and union members.Ms2ger2017-02-161-1/+1
|
* Update js.Ms2ger2017-02-151-2/+2
| | | | Fixes #15553.
* Use an ArrayBuffer to implement readAsArrayBuffer.Ms2ger2017-01-191-2/+2
|
* Removed util.Alan Jeffrey2016-12-141-3/+4
|
* Remove HeapGCValueAnthony Ramine2016-12-121-3/+3
| | | | | | It could be used to have mutable JSVal fields without GC barriers. With the removal of that trait, MutHeap and MutNullableHeap can respectively be replaced by MutJS and MutNullableJS.
* Rename `Reflectable` to `DomObject`.Corey Farwell2016-12-081-1/+1
| | | | Fixes https://github.com/servo/servo/issues/8473.
* script creates methods taking '*mut JSContext' unsafeAbelardo E. Mendoza2016-11-141-4/+2
| | | | rebase + marked the necessary new code as unsafe
* Update to string-cache 0.3Simon Sapin2016-11-031-1/+1
|
* Update js.Ms2ger2016-11-021-1/+1
|
* Implemented FileReader::readAsArrayBufferNikhil Shagrithaya2016-11-011-15/+59
|
* Rename Reflectable::global_scope to globalAnthony Ramine2016-10-061-5/+5
|
* Remove Reflectable::globalAnthony Ramine2016-10-061-0/+1
|
* Introduce GlobalScope::file_reading_task_sourceAnthony Ramine2016-10-061-3/+4
|
* Introduce GlobalScope::get_runnable_wrapperAnthony Ramine2016-10-061-1/+1
|
* Pass a &GlobalScope to WebIDL static methods and constructorsAnthony Ramine2016-10-061-3/+2
|
* Introduce Reflectable::global_scopeAnthony Ramine2016-10-061-8/+4
|
* Make reflect_dom_object take a &GlobalScopeAnthony Ramine2016-10-061-6/+7
|
* Implement file reading task sourceKeith Yeung2016-07-141-44/+18
| | | | And remove superfluous FileReaderEvent enum
* Implements name method for FilerReader event from trait RunnableNikhil Shagrithaya2016-07-101-0/+2
|
* Remove DataSlice, fix #12249Zhen Zhang2016-07-051-8/+8
|
* Add file backend support for Blob and relatedZhen Zhang2016-06-011-1/+1
| | | | | | | | Changes include: - Add BlobImpl to Blob, and related caching mechanism - Expose ResourceThreads to document_loader, workerglobalscope, worker, and global - Fix encode_multipart_form_data - Other small fixes to accommodate the above changes
* Remove empty lines following braces.Josh Matthews2016-05-271-3/+1
|
* Move DOMString back to scriptAnthony Ramine2016-05-241-1/+1
| | | | This entirely removes the 'non-geckolib' feature of the util crate.
* Remove extraneous script_chan parameter from Trusted::newKeith Yeung2016-04-281-4/+2
|
* refactors entities from script_thread into script_runtimeRahul Sharma2016-04-061-2/+3
|
* Issue #9561 continued - renamed *_thread_source to *_task_source in ↵Kamil Muszyński2016-02-171-2/+2
| | | | global.rs and related files
* Add global default method for Reflectable traitChad Kimes2016-01-111-6/+6
|
* Remove global field from FileReaderChad Kimes2016-01-101-10/+8
|
* task -> threadrohan.prinja2016-01-101-12/+12
|
* Changed blob to use DataSlice with Arc in order to limit wasteful copying of ↵David Raifaizen2016-01-061-27/+16
| | | | byte vector
* Remove from Trusted::new an unnecessary argumentArthur Skobara2015-12-121-1/+1
|
* Pass around event types as Atoms instead of StringsCorey Farwell2015-12-101-11/+12
| | | | | | `Event` internally stores the `type` as an `Atom`, and we're `String`s everywhere, which can cause unnecessary allocations to occur since they'll end up as `Atom`s anyways.
* Split fn script_chan into 5 different task channel fnKeith Yeung2015-12-061-2/+2
|
* Replaced DOMString constructor by conversion functions.Alan Jeffrey2015-11-121-3/+3
| | | | | | Replaced DOMString(...) by DOMString::from(...). Replaced ....0 by String::from(...). Removed any uses of .to_owner() in DOMString::from("...").
* Replaced DOMString by String in filereader.Alan Jeffrey2015-11-121-9/+8
|