Commit message (Collapse) | Author | Age | Files | Lines | |
---|---|---|---|---|---|
* | Strict import formatting (grouping and granularity) (#30325) | Samson | 2023-09-11 | 1 | -4/+6 |
| | | | | | * strict imports formatting * Reformat all imports | ||||
* | Add trait DomObjectWrap to provide WRAP function | YUAN LYU | 2020-03-20 | 1 | -4/+1 |
| | |||||
* | Rustfmt has changed its default style :/ | Simon Sapin | 2018-12-28 | 1 | -1/+1 |
| | |||||
* | Update MPL license to https (part 3) | Jan Andre Ikenmeyer | 2018-11-19 | 1 | -1/+1 |
| | |||||
* | Reorder imports | Pyfisch | 2018-11-06 | 1 | -4/+8 |
| | |||||
* | `cargo fix --edition` | Simon Sapin | 2018-11-06 | 1 | -15/+15 |
| | |||||
* | Format script component | chansuke | 2018-09-19 | 1 | -16/+28 |
| | |||||
* | Remove use of unstable box syntax. | Simon Sapin | 2017-10-16 | 1 | -1/+1 |
| | | | | | | | | | | | | | | | | | | | | http://www.robohornet.org gives a score of 101.36 on master, and 102.68 with this PR. The latter is slightly better, but probably within noise level. So it looks like this PR does not affect DOM performance. This is expected since `Box::new` is defined as: ```rust impl<T> Box<T> { #[inline(always)] pub fn new(x: T) -> Box<T> { box x } } ``` With inlining, it should compile to the same as box syntax. | ||||
* | Rename Root<T> to DomRoot<T> | Anthony Ramine | 2017-09-26 | 1 | -6/+6 |
| | | | | | | | In a later PR, DomRoot<T> will become a type alias of Root<Dom<T>>, where Root<T> will be able to handle all the things that need to be rooted that have a stable traceable address that doesn't move for the whole lifetime of the root. Stay tuned. | ||||
* | Rename DOMRefCell<T> to DomRefCell<T> | Anthony Ramine | 2017-09-26 | 1 | -3/+3 |
| | | | | | | | | I don't want to do such a gratuitous rename, but with all the other types now having "Dom" as part of their name, and especially with "DomOnceCell", I feel like the other cell type that we already have should also follow the convention. That argument loses weight though when we realise there is still DOMString and other things. | ||||
* | Rename JS<T> to Dom<T> | Anthony Ramine | 2017-09-26 | 1 | -6/+6 |
| | |||||
* | Rename dom::bindings::js to dom::bindings::root | Anthony Ramine | 2017-09-26 | 1 | -1/+1 |
| | |||||
* | Remove JSContext argument from AsyncBluetoothListener::handle_response | Anthony Ramine | 2017-09-22 | 1 | -7/+1 |
| | |||||
* | Make Promise::reject_error sound | Anthony Ramine | 2017-09-22 | 1 | -2/+7 |
| | |||||
* | Make Promise::resolve_native actually sound | Anthony Ramine | 2017-09-21 | 1 | -2/+2 |
| | | | | | We shouldn't have to pass a raw JSContext pointer, and to enter the promise's context's compartment by hand. | ||||
* | Make #[dom_struct] a proc_macro attribute | Anthony Ramine | 2017-02-24 | 1 | -0/+1 |
| | |||||
* | refactor extra permission data | Attila Dusnoki | 2017-02-14 | 1 | -6/+1 |
| | |||||
* | Move extra permission data to window | Attila Dusnoki | 2017-02-13 | 1 | -2/+2 |
| | |||||
* | Fix BluetoothPermissionResult return state | Attila Dusnoki | 2017-02-13 | 1 | -1/+2 |
| | |||||
* | Fix comments, and lesser modifications | Zakor Gyula | 2017-02-13 | 1 | -5/+5 |
| | |||||
* | Bluetooth Permission API integration | Zakor Gyula | 2017-02-13 | 1 | -0/+128 |