aboutsummaryrefslogtreecommitdiffstats
path: root/tests/wpt/web-platform-tests/tools/html5lib/setup.py
diff options
context:
space:
mode:
authorWPT Sync Bot <josh+wptsync@joshmatthews.net>2018-06-08 21:05:21 -0400
committerWPT Sync Bot <josh+wptsync@joshmatthews.net>2018-06-08 22:44:24 -0400
commitfe00a63040da3ead9ef3703d5094d3f1e36bffd4 (patch)
tree6c387c7863764aa4f74b58722373f6ac6e14b209 /tests/wpt/web-platform-tests/tools/html5lib/setup.py
parent527d874bc107039156d40d25b2a76f4a28eb639e (diff)
downloadservo-fe00a63040da3ead9ef3703d5094d3f1e36bffd4.tar.gz
servo-fe00a63040da3ead9ef3703d5094d3f1e36bffd4.zip
Update web-platform-tests to revision 132d12daea699ce266324e79eecbe59b10e56502
Diffstat (limited to 'tests/wpt/web-platform-tests/tools/html5lib/setup.py')
-rw-r--r--tests/wpt/web-platform-tests/tools/html5lib/setup.py44
1 files changed, 0 insertions, 44 deletions
diff --git a/tests/wpt/web-platform-tests/tools/html5lib/setup.py b/tests/wpt/web-platform-tests/tools/html5lib/setup.py
deleted file mode 100644
index f75910eaf21..00000000000
--- a/tests/wpt/web-platform-tests/tools/html5lib/setup.py
+++ /dev/null
@@ -1,44 +0,0 @@
-from distutils.core import setup
-import os
-import codecs
-
-classifiers=[
- 'Development Status :: 5 - Production/Stable',
- 'Intended Audience :: Developers',
- 'License :: OSI Approved :: MIT License',
- 'Operating System :: OS Independent',
- 'Programming Language :: Python',
- 'Programming Language :: Python :: 2',
- 'Programming Language :: Python :: 2.6',
- 'Programming Language :: Python :: 2.7',
- 'Programming Language :: Python :: 3',
- 'Programming Language :: Python :: 3.2',
- 'Programming Language :: Python :: 3.3',
- 'Topic :: Software Development :: Libraries :: Python Modules',
- 'Topic :: Text Processing :: Markup :: HTML'
- ]
-
-packages = ['html5lib'] + ['html5lib.'+name
- for name in os.listdir(os.path.join('html5lib'))
- if os.path.isdir(os.path.join('html5lib', name)) and
- not name.startswith('.') and name != 'tests']
-
-current_dir = os.path.dirname(__file__)
-with codecs.open(os.path.join(current_dir, 'README.rst'), 'r', 'utf8') as readme_file:
- with codecs.open(os.path.join(current_dir, 'CHANGES.rst'), 'r', 'utf8') as changes_file:
- long_description = readme_file.read() + '\n' + changes_file.read()
-
-setup(name='html5lib',
- version='0.9999-dev',
- url='https://github.com/html5lib/html5lib-python',
- license="MIT License",
- description='HTML parser based on the WHATWG HTML specifcation',
- long_description=long_description,
- classifiers=classifiers,
- maintainer='James Graham',
- maintainer_email='james@hoppipolla.co.uk',
- packages=packages,
- install_requires=[
- 'six',
- ],
- )