aboutsummaryrefslogtreecommitdiffstats
path: root/python/tidy/setup.py
diff options
context:
space:
mode:
authorAskeing Yen (fyen) <askeing@gmail.com>2016-04-13 16:00:23 -0700
committeredunham <edunham@mozilla.com>2016-04-13 16:07:04 -0700
commitaf2ca1fa8076a5ab78f1162aaac819bb8e826ca3 (patch)
tree6342d11b329eb247c1a4580a57ae6f6ec86e77d9 /python/tidy/setup.py
parent711bfe2860a308acc12a7c0437b9832d3d454c1f (diff)
downloadservo-af2ca1fa8076a5ab78f1162aaac819bb8e826ca3.tar.gz
servo-af2ca1fa8076a5ab78f1162aaac819bb8e826ca3.zip
Create a Python package of Tidy
Diffstat (limited to 'python/tidy/setup.py')
-rw-r--r--python/tidy/setup.py40
1 files changed, 40 insertions, 0 deletions
diff --git a/python/tidy/setup.py b/python/tidy/setup.py
new file mode 100644
index 00000000000..7221e6c1463
--- /dev/null
+++ b/python/tidy/setup.py
@@ -0,0 +1,40 @@
+import os
+from setuptools import setup, find_packages
+
+
+VERSION = '0.0.1'
+
+install_requires = [
+]
+
+here = os.path.dirname(os.path.abspath(__file__))
+# get documentation from the README and HISTORY
+try:
+ with open(os.path.join(here, 'README.rst')) as doc:
+ readme = doc.read()
+except:
+ readme = ''
+
+try:
+ with open(os.path.join(here, 'HISTORY.rst')) as doc:
+ history = doc.read()
+except:
+ history = ''
+
+long_description = readme + '\n\n' + history
+
+if __name__ == '__main__':
+ setup(
+ name='servo_tidy',
+ version=VERSION,
+ description='The tidy package of Servo',
+ long_description=long_description,
+ keywords='mozilla servo tidy ',
+ author='The Servo Project Developers',
+ author_email='dev-servo@lists.mozilla.org',
+ url='https://github.com/servo/servo_tindy',
+ packages=find_packages(exclude=['ez_setup', 'examples', 'tests']),
+ package_data={},
+ install_requires=install_requires,
+ zip_safe=False,
+ )