aboutsummaryrefslogtreecommitdiffstats
path: root/python/mach/setup.py
diff options
context:
space:
mode:
authorJonathan Schwender <55576758+jschwe@users.noreply.github.com>2024-09-11 20:25:25 +0200
committerGitHub <noreply@github.com>2024-09-11 18:25:25 +0000
commitb42f5eaa17c897270e9de5dadc6ab19fb1dfff43 (patch)
tree8a95e6d1bc308d7fce16aaf7af738ddea6203bec /python/mach/setup.py
parented5dc43f160993ff491e2eab17fae1db872ed964 (diff)
downloadservo-b42f5eaa17c897270e9de5dadc6ab19fb1dfff43.tar.gz
servo-b42f5eaa17c897270e9de5dadc6ab19fb1dfff43.zip
mach: remove python2 compatibility code (#33410)
* util.py: Remove six We don't need to support python2 anymore, so we can just use `str(x)` instead of `six.ensure_str(x)` Signed-off-by: Jonathan Schwender <schwenderjonathan@gmail.com> * config.py: Remove six We don't need to support python2 anymore, so we can just use `str(x)` instead of `six.ensure_str(x)` Signed-off-by: Jonathan Schwender <schwenderjonathan@gmail.com> * main.py: Remove six We don't need to support python2 anymore, so we can just use `str(x)` instead of `six.ensure_str(x)` Signed-off-by: Jonathan Schwender <schwenderjonathan@gmail.com> * main.py: Fix `--settings` being ignored Previously `paths` was unused in this function, and the usage for the settings_file would have no effect. Signed-off-by: Jonathan Schwender <schwenderjonathan@gmail.com> * terminal.py: Remove `six` Signed-off-by: Jonathan Schwender <schwenderjonathan@gmail.com> * registrar.py: Remove `six` Signed-off-by: Jonathan Schwender <schwenderjonathan@gmail.com> * mach/util.py: Remove `six` Signed-off-by: Jonathan Schwender <schwenderjonathan@gmail.com> * mach: Remove python2 from the list of programming languages Signed-off-by: Jonathan Schwender <schwenderjonathan@gmail.com> --------- Signed-off-by: Jonathan Schwender <schwenderjonathan@gmail.com>
Diffstat (limited to 'python/mach/setup.py')
-rw-r--r--python/mach/setup.py3
1 files changed, 1 insertions, 2 deletions
diff --git a/python/mach/setup.py b/python/mach/setup.py
index 779a18aed4b..0c96a083e6d 100644
--- a/python/mach/setup.py
+++ b/python/mach/setup.py
@@ -26,8 +26,7 @@ setup(
'Development Status :: 5 - Production/Stable',
'License :: OSI Approved :: Mozilla Public License 2.0 (MPL 2.0)',
'Natural Language :: English',
- 'Programming Language :: Python :: 2.7',
- 'Programming Language :: Python :: 3.5',
+ 'Programming Language :: Python :: 3.10',
],
install_requires=[
'blessings',