aboutsummaryrefslogtreecommitdiffstats
path: root/python/mach/setup.py
diff options
context:
space:
mode:
authorJosh Matthews <josh@joshmatthews.net>2021-12-21 10:57:18 -0500
committerJosh Matthews <josh@joshmatthews.net>2021-12-21 10:57:18 -0500
commitf4de057784291f9619191f22b386d9b699507667 (patch)
treee0d6a564ae945efc002e7d06cb9808c5aff1b0b4 /python/mach/setup.py
parent8dc59c698529bf7ca45f06f468311414dd132fce (diff)
downloadservo-f4de057784291f9619191f22b386d9b699507667.tar.gz
servo-f4de057784291f9619191f22b386d9b699507667.zip
Vendor mach-1.0.0.
Diffstat (limited to 'python/mach/setup.py')
-rw-r--r--python/mach/setup.py41
1 files changed, 41 insertions, 0 deletions
diff --git a/python/mach/setup.py b/python/mach/setup.py
new file mode 100644
index 00000000000..12fd396f3f0
--- /dev/null
+++ b/python/mach/setup.py
@@ -0,0 +1,41 @@
+# This Source Code Form is subject to the terms of the Mozilla Public
+# License, v. 2.0. If a copy of the MPL was not distributed with this
+# file, You can obtain one at http://mozilla.org/MPL/2.0/.
+
+from __future__ import absolute_import
+try:
+ from setuptools import setup
+except ImportError:
+ from distutils.core import setup
+
+
+VERSION = '1.0.0'
+
+README = open('README.rst').read()
+
+setup(
+ name='mach',
+ description='Generic command line command dispatching framework.',
+ long_description=README,
+ license='MPL 2.0',
+ author='Gregory Szorc',
+ author_email='gregory.szorc@gmail.com',
+ url='https://developer.mozilla.org/en-US/docs/Developer_Guide/mach',
+ packages=['mach', 'mach.mixin'],
+ version=VERSION,
+ classifiers=[
+ 'Environment :: Console',
+ 'Development Status :: 5 - Production/Stable',
+ 'License :: OSI Approved :: Mozilla Public License 2.0 (MPL 2.0)',
+ 'Natural Language :: English',
+ 'Programming Language :: Python :: 2.7',
+ 'Programming Language :: Python :: 3.5',
+ ],
+ install_requires=[
+ 'blessings',
+ 'mozfile',
+ 'mozprocess',
+ 'six',
+ ],
+ tests_require=['mock'],
+)