aboutsummaryrefslogtreecommitdiffstats
path: root/components/script/dom/bindings/codegen/ply/setup.py
diff options
context:
space:
mode:
authorsagudev <16504129+sagudev@users.noreply.github.com>2023-02-19 13:38:01 +0100
committersagudev <16504129+sagudev@users.noreply.github.com>2023-02-19 13:38:01 +0100
commit2acdeabaf59dc233e4a9e96c36c7bf0df574f0c6 (patch)
tree47b5a96cbdbdeada8f143d299a91c16a0ea7822f /components/script/dom/bindings/codegen/ply/setup.py
parent4d393612b49343b141acdbe5a0b5dd7acc43eb65 (diff)
downloadservo-2acdeabaf59dc233e4a9e96c36c7bf0df574f0c6.tar.gz
servo-2acdeabaf59dc233e4a9e96c36c7bf0df574f0c6.zip
Update ply
Diffstat (limited to 'components/script/dom/bindings/codegen/ply/setup.py')
-rw-r--r--components/script/dom/bindings/codegen/ply/setup.py31
1 files changed, 31 insertions, 0 deletions
diff --git a/components/script/dom/bindings/codegen/ply/setup.py b/components/script/dom/bindings/codegen/ply/setup.py
new file mode 100644
index 00000000000..ee8ccd0ccf5
--- /dev/null
+++ b/components/script/dom/bindings/codegen/ply/setup.py
@@ -0,0 +1,31 @@
+try:
+ from setuptools import setup
+except ImportError:
+ from distutils.core import setup
+
+setup(name = "ply",
+ description="Python Lex & Yacc",
+ long_description = """
+PLY is yet another implementation of lex and yacc for Python. Some notable
+features include the fact that its implemented entirely in Python and it
+uses LALR(1) parsing which is efficient and well suited for larger grammars.
+
+PLY provides most of the standard lex/yacc features including support for empty
+productions, precedence rules, error recovery, and support for ambiguous grammars.
+
+PLY is extremely easy to use and provides very extensive error checking.
+It is compatible with both Python 2 and Python 3.
+""",
+ license="""BSD""",
+ version = "3.10",
+ author = "David Beazley",
+ author_email = "dave@dabeaz.com",
+ maintainer = "David Beazley",
+ maintainer_email = "dave@dabeaz.com",
+ url = "http://www.dabeaz.com/ply/",
+ packages = ['ply'],
+ classifiers = [
+ 'Programming Language :: Python :: 3',
+ 'Programming Language :: Python :: 2',
+ ]
+ )