aboutsummaryrefslogtreecommitdiffstats
path: root/components/script/Cargo.toml
diff options
context:
space:
mode:
authorJosh Matthews <josh@joshmatthews.net>2025-01-18 16:36:15 -0500
committerGitHub <noreply@github.com>2025-01-18 21:36:15 +0000
commit875e3870049d2523ec349724d692a11665562d40 (patch)
tree22f6c6bc078bdb1f44567d4bc99d9b0450986309 /components/script/Cargo.toml
parent1bd34a578117fdefb8ec20e5cbe49b38dd466c5b (diff)
downloadservo-875e3870049d2523ec349724d692a11665562d40.tar.gz
servo-875e3870049d2523ec349724d692a11665562d40.zip
script: Feature-gate all crown support. (#35055)
* script: Feature-gate all crown support. Signed-off-by: Josh Matthews <josh@joshmatthews.net> * script: Use cfg(crown) instead of a cargo feature. Signed-off-by: Josh Matthews <josh@joshmatthews.net> --------- Signed-off-by: Josh Matthews <josh@joshmatthews.net>
Diffstat (limited to 'components/script/Cargo.toml')
-rw-r--r--components/script/Cargo.toml6
1 files changed, 5 insertions, 1 deletions
diff --git a/components/script/Cargo.toml b/components/script/Cargo.toml
index c9db4b52034..2934bfec419 100644
--- a/components/script/Cargo.toml
+++ b/components/script/Cargo.toml
@@ -13,6 +13,7 @@ name = "script"
path = "lib.rs"
[features]
+crown = ['js/crown']
debugmozjs = ['js/debugmozjs']
jitspew = ['js/jitspew']
profilemozjs = ['js/profilemozjs']
@@ -23,6 +24,9 @@ refcell_backtrace = ["accountable-refcell"]
webxr = ["webxr-api"]
webgpu = []
+[lints.rust]
+unexpected_cfgs = { level = "warn", check-cfg = ['cfg(crown)'] }
+
[build-dependencies]
phf_codegen = "0.11"
phf_shared = "0.11"
@@ -72,7 +76,7 @@ image = { workspace = true }
indexmap = { workspace = true }
ipc-channel = { workspace = true }
itertools = { workspace = true }
-js = { package = "mozjs", git = "https://github.com/servo/mozjs", features = ["crown"] }
+js = { package = "mozjs", git = "https://github.com/servo/mozjs" }
jstraceable_derive = { path = "../jstraceable_derive" }
keyboard-types = { workspace = true }
libc = { workspace = true }