aboutsummaryrefslogtreecommitdiffstats
path: root/components/script/Cargo.toml
diff options
context:
space:
mode:
authorMartin Robinson <mrobinson@igalia.com>2025-04-04 13:52:58 +0200
committerGitHub <noreply@github.com>2025-04-04 11:52:58 +0000
commit49d48b897ae0c310a380a498baf8e38518172e3e (patch)
treebc1018411158f8c7e165e42551a23f17617c10ff /components/script/Cargo.toml
parent1f928252e37fecc251e74bf23d7105d285b8a906 (diff)
downloadservo-49d48b897ae0c310a380a498baf8e38518172e3e.tar.gz
servo-49d48b897ae0c310a380a498baf8e38518172e3e.zip
script: Remove dependency on `webgpu` (#36332)
After #36320, `script` only depends on `webgpu` for its type aliases to `wgpu_core` and `wgpu_types`. This change removes the dependency on `webgpu` in favor of depending directly on the upstream crates. This makes it so that you can change `webgpu` without recompiling `script`. Testing: This change is covered by existing WebGPU tests and is mainly just changing the way dependencies are accessed. Signed-off-by: Martin Robinson <mrobinson@igalia.com> Signed-off-by: Martin Robinson <mrobinson@igalia.com>
Diffstat (limited to 'components/script/Cargo.toml')
-rw-r--r--components/script/Cargo.toml3
1 files changed, 2 insertions, 1 deletions
diff --git a/components/script/Cargo.toml b/components/script/Cargo.toml
index ede6b9fb941..872ae7d6da5 100644
--- a/components/script/Cargo.toml
+++ b/components/script/Cargo.toml
@@ -132,11 +132,12 @@ url = { workspace = true }
utf-8 = "0.7"
uuid = { workspace = true, features = ["serde"] }
webdriver = { workspace = true }
-webgpu = { path = "../webgpu" }
webgpu_traits = { workspace = true }
webrender_api = { workspace = true }
webrender_traits = { workspace = true }
webxr-api = { workspace = true, features = ["ipc"], optional = true }
+wgpu-core = { workspace = true }
+wgpu-types = { workspace = true }
xml5ever = { workspace = true }
[target.'cfg(not(target_os = "ios"))'.dependencies]