aboutsummaryrefslogtreecommitdiffstats
path: root/components/script/Cargo.toml
diff options
context:
space:
mode:
authorVincent Ricard <magic@magicninja.org>2020-10-29 18:03:22 +0100
committerVincent Ricard <magic@magicninja.org>2020-11-18 18:14:51 +0100
commit43b3d93aec58664ce013b255b0d498ead33b74f8 (patch)
tree702a3fa5c20411c4e05d70b34f1f4867a9919144 /components/script/Cargo.toml
parent15a435a7ae0a7ae2cf408ad6a1ef3702bd6ce88d (diff)
downloadservo-43b3d93aec58664ce013b255b0d498ead33b74f8.tar.gz
servo-43b3d93aec58664ce013b255b0d498ead33b74f8.zip
Use data_url::Mime to parse the MIME Types
This commit follows the spectification https://fetch.spec.whatwg.org/#concept-header-extract-mime-type
Diffstat (limited to 'components/script/Cargo.toml')
-rw-r--r--components/script/Cargo.toml1
1 files changed, 1 insertions, 0 deletions
diff --git a/components/script/Cargo.toml b/components/script/Cargo.toml
index d155919ba12..3a3767906a1 100644
--- a/components/script/Cargo.toml
+++ b/components/script/Cargo.toml
@@ -43,6 +43,7 @@ content-security-policy = { version = "0.4.0", features = ["serde"] }
cookie = "0.11"
crossbeam-channel = "0.4"
cssparser = "0.27"
+data-url = "0.1.0"
deny_public_fields = { path = "../deny_public_fields" }
devtools_traits = { path = "../devtools_traits" }
dom_struct = { path = "../dom_struct" }