aboutsummaryrefslogtreecommitdiffstats
path: root/components/script/Cargo.toml
diff options
context:
space:
mode:
authorJosh Matthews <josh@joshmatthews.net>2024-11-24 13:01:35 -0500
committerGitHub <noreply@github.com>2024-11-24 18:01:35 +0000
commit3faed9b9212fee1f0ff9be5f7cfb5e24c5b84b91 (patch)
treef59efff26edc58b9cd32c08da070a6e27655ae82 /components/script/Cargo.toml
parente956f3124c230549c6ef4a63e2c27e56d0965453 (diff)
downloadservo-3faed9b9212fee1f0ff9be5f7cfb5e24c5b84b91.tar.gz
servo-3faed9b9212fee1f0ff9be5f7cfb5e24c5b84b91.zip
Filter out webidl files based on special comments, and feature-gate webxr interfaces. (#34348)
* Filter out webidl files based on skip-if directives. Signed-off-by: Josh Matthews <josh@joshmatthews.net> * script: Don't build XR functionality without webxr feature. Signed-off-by: Josh Matthews <josh@joshmatthews.net> * Fix tidy. Signed-off-by: Josh Matthews <josh@joshmatthews.net> * script: Adjust imports for file movement. Signed-off-by: Josh Matthews <josh@joshmatthews.net> * Fix clippy. Signed-off-by: Josh Matthews <josh@joshmatthews.net> * Formatting. Signed-off-by: Josh Matthews <josh@joshmatthews.net> * Clean up webxr module import. Co-authored-by: Samson <16504129+sagudev@users.noreply.github.com> Signed-off-by: Josh Matthews <josh@joshmatthews.net> --------- Signed-off-by: Josh Matthews <josh@joshmatthews.net> Co-authored-by: Samson <16504129+sagudev@users.noreply.github.com>
Diffstat (limited to 'components/script/Cargo.toml')
-rw-r--r--components/script/Cargo.toml3
1 files changed, 2 insertions, 1 deletions
diff --git a/components/script/Cargo.toml b/components/script/Cargo.toml
index cf003639e67..a1793318fd3 100644
--- a/components/script/Cargo.toml
+++ b/components/script/Cargo.toml
@@ -20,6 +20,7 @@ tracing = ["dep:tracing"]
webgl_backtrace = ["canvas_traits/webgl_backtrace"]
js_backtrace = []
refcell_backtrace = ["accountable-refcell"]
+webxr = ["webxr-api"]
[build-dependencies]
phf_codegen = "0.11"
@@ -126,7 +127,7 @@ webdriver = { workspace = true }
webgpu = { path = "../webgpu" }
webrender_api = { workspace = true }
webrender_traits = { workspace = true }
-webxr-api = { workspace = true, features = ["ipc"] }
+webxr-api = { workspace = true, features = ["ipc"], optional = true }
xml5ever = { workspace = true }
[target.'cfg(not(target_os = "ios"))'.dependencies]