aboutsummaryrefslogtreecommitdiffstats
path: root/components/script/Cargo.toml
diff options
context:
space:
mode:
authorMartin Robinson <mrobinson@igalia.com>2024-12-24 10:53:35 +0100
committerGitHub <noreply@github.com>2024-12-24 09:53:35 +0000
commit226299380d8506b22692f2ab4302564cd33c42ff (patch)
tree6ddf2131e9def28f724afa0a92b4546a69de1e77 /components/script/Cargo.toml
parentff7626bfc61aef3a294c0e286c124fb3f5bed495 (diff)
downloadservo-226299380d8506b22692f2ab4302564cd33c42ff.tar.gz
servo-226299380d8506b22692f2ab4302564cd33c42ff.zip
script: Make timers per-process (#34581)
Before all timers were managed by the Constellation process, meaning that they had to trigger IPC calls to be scheduled and fired. Currently, timers are only used in the `ScriptThread`, so it makes sense that they are per-process. This change restores the timer thread functionality that existed before avoided entirely. Completion is done using a callback that is sent to the timer thread similarly to how fetch is done. This allows reusing the existing task queue without making any new channels. Fixes #15219. Signed-off-by: Martin Robinson <mrobinson@igalia.com>
Diffstat (limited to 'components/script/Cargo.toml')
-rw-r--r--components/script/Cargo.toml1
1 files changed, 1 insertions, 0 deletions
diff --git a/components/script/Cargo.toml b/components/script/Cargo.toml
index 98aec5908ec..c9db4b52034 100644
--- a/components/script/Cargo.toml
+++ b/components/script/Cargo.toml
@@ -118,6 +118,7 @@ swapper = "0.1"
tempfile = "3"
tendril = { version = "0.4.1", features = ["encoding_rs"] }
time_03 = { workspace = true }
+timers = { path = "../timers" }
tracing = { workspace = true, optional = true }
unicode-bidi = { workspace = true }
unicode-segmentation = { workspace = true }