aboutsummaryrefslogtreecommitdiffstats
path: root/Cargo.toml
diff options
context:
space:
mode:
authorJack Moffitt <jack@metajack.im>2014-08-28 09:34:23 -0600
committerJack Moffitt <jack@metajack.im>2014-09-08 20:21:42 -0600
commitc6ab60dbfc6da7b4f800c9e40893c8b58413960c (patch)
treed1d74076cf7fa20e4f77ec7cb82cae98b67362cb /Cargo.toml
parentdb2f642c32fc5bed445bb6f2e45b0f6f0b4342cf (diff)
downloadservo-c6ab60dbfc6da7b4f800c9e40893c8b58413960c.tar.gz
servo-c6ab60dbfc6da7b4f800c9e40893c8b58413960c.zip
Cargoify servo
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml51
1 files changed, 51 insertions, 0 deletions
diff --git a/Cargo.toml b/Cargo.toml
new file mode 100644
index 00000000000..a5cc706c002
--- /dev/null
+++ b/Cargo.toml
@@ -0,0 +1,51 @@
+[package]
+
+name = "servo"
+version = "0.0.1"
+authors = ["The Servo Project Developers"]
+
+[lib]
+name = "servo"
+crate-type = ["rlib", "dylib"]
+
+[[bin]]
+name = "servo"
+test = false
+doc = false
+bench = false
+
+[[test]]
+name = "reftest"
+path = "tests/reftest.rs"
+harness = false
+
+[[test]]
+name = "contenttest"
+path = "tests/contenttest.rs"
+harness = false
+
+
+[dependencies.compositing]
+path = "components/compositing"
+
+[dependencies.net]
+path = "components/net"
+
+[dependencies.msg]
+path = "components/msg"
+
+[dependencies.util]
+path = "components/util"
+
+[dependencies.script]
+path = "components/script"
+
+[dependencies.layout]
+path = "components/layout"
+
+[dependencies.gfx]
+path = "components/gfx"
+
+[dependencies.png]
+git = "https://github.com/servo/rust-png"
+