aboutsummaryrefslogtreecommitdiffstats
path: root/Cargo.toml
diff options
context:
space:
mode:
authorbors-servo <servo-ops@mozilla.com>2020-04-29 00:18:36 -0400
committerGitHub <noreply@github.com>2020-04-29 00:18:36 -0400
commitba0df48d47d44456e0eb89caae97ae8423f20995 (patch)
tree4a429a5f791ca2e4bb0725b31124bb82782b74e7 /Cargo.toml
parent1aab10f20aa1409ce59577d0d383b8001d440296 (diff)
parentab7ade4efe3be188fe3ae0548fdd38eab619a501 (diff)
downloadservo-ba0df48d47d44456e0eb89caae97ae8423f20995.tar.gz
servo-ba0df48d47d44456e0eb89caae97ae8423f20995.zip
Auto merge of #26346 - jdm:console-caller, r=Manishearth
Improve devtools output for console APIs These changes use the new API from https://github.com/servo/rust-mozjs/pull/508 to report meaningful filenames and line numbers for APIs that trigger devtools output. They also cause error messages originating from uncompiled event handlers to report a more relevant filename; this differs from Gecko's behaviour, but provides a more useful debugging experience in my opinion. --- - [x] `./mach build -d` does not report any errors - [x] `./mach test-tidy` does not report any errors - [x] These changes fix #9604 and fix #26344. - [x] These changes do not require tests because devtools aren't tested.
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml1
1 files changed, 1 insertions, 0 deletions
diff --git a/Cargo.toml b/Cargo.toml
index c1d7986da5f..6f37b4f3f7c 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -33,3 +33,4 @@ winapi = { git = "https://github.com/servo/winapi-rs", branch = "patch-1" }
spirv_cross = { git = "https://github.com/servo/spirv_cross", branch = "wgpu-servo" }
surfman-chains = { git = "https://github.com/asajeffrey/surfman-chains" }
surfman = { git = "https://github.com/servo/surfman" }
+